cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Observer
Observer
243 Views
Registered: ‎08-04-2017

[ZedBoard 7z020] [Video] hang at "starting kernel..."

 

Hi all, yes I'm aware there are 100 of these threads, but ive read a lot of them and tried a lot of the solutions, building my own petalinux, giving debug options, all to no avail.


[Update]: I made a 3:00 min video showing how standalone programs work, but petalinux does not:


So I am following the Zynq tutorial here: https://www.xilinx.com/support/documentation/sw_manuals/xilinx2020_1/ug1165-zynq-embedded-design-tutorial.pdf

And I've got to Chapter 2 succesfully - I can:

  • Create Zynq block design
  • Export hardware configuration
  • Create hardware platform in Vitis
  • Create hello world project in Vitis
  • I see "Hello World" appear in the Vitis serial monitor, and I can debug it too.

So that I'm happy with. But now I want to run Linux, and I am following Chapter 6. The problem is, the Vitis serial monitor does not print anything past the "Starting kernel..." line.

What I've tried:

  • Passing "setenv bootargs console=ttyPS1,115200 earlyprintk=serial,ttyPS1,115200" to u-boot
  • Passing "setenv bootargs console=ttyPS0,115200 earlyprintk=serial,ttyPS0,115200" to u-boot
  • Building petalinux from scratch using my hardware configuration .xsa file
  • Building petalinux, and reconfiguring kernel to give early debug and early printk [LINK]
  • Building petalinux, and reconfiguring kernel to disable Xilinx GPIO [LINK]

Here is what my block design looks like (Identical to Chapter 2 in the tutorial):

Top-level block designTop-level block design

And here is what the Zynq configuration looks like at a glance (Notice UART1 is enabled - is that right?)

Zynq configuration at a glanceZynq configuration at a glance

I am happy to provide more information. Will be very appreciative of any ideas people have!


Maxim

0 Kudos
Reply
0 Replies