UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Visitor bjay1435
Visitor
1,830 Views
Registered: ‎09-13-2016

Zedboard USB not working...

Hi all,

 

Embedded Linux noob here, I'm trying to use a USB webcam with Xilinx's supported Linux release "Xilinx-v2016.2" running on the zedboard, but it doesn't recognize or provide power to a device when i plug it in. In contrast, when i run "usb start" in the uboot console before booting the kernel, it powers any connected device (I've been using my phone as a test, it charges when I run "usb start" or "usb reset" and then when I boot, it no longer chargers). 

 

I've set up my kernel according to this link (http://www.wiki.xilinx.com/Zynq+Linux+USB+Device+Driver) but to no avail.

 

Any help would be appreciated!

Tags (4)
0 Kudos