UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Observer ain0102
Observer
935 Views
Registered: ‎02-06-2018

Zynq UltraScale MPSoC Base TRD 2017.4 DM1

Jump to solution

Hi.

 

I am following the wiki posted here.

 

http://www.wiki.xilinx.com/Zynq+UltraScale+MPSoC+Base+TRD+2017.4+-+Design+Module+1

 

If I do petalinux-build on DM1, I get the following error.

 

Attach the build.log file as follows.

 

How do I fix this? please help me.

 

ERROR: qtbase-native-5.7.1+gitAUTOINC+a55f36211e-r0 do_compile: oe_runmake failed
ERROR: qtbase-native-5.7.1+gitAUTOINC+a55f36211e-r0 do_compile: Function failed: do_compile (log file is located at /data1/hccho/zcu102_trd/apu/petalinux_bsp/build/tmp/work/x86_64-linux/qtbase-native/5.7.1+gitAUTOINC+a55f36211e-r0/temp/log.do_compile.2214)
ERROR: Logfile of failure stored in: /data1/hccho/zcu102_trd/apu/petalinux_bsp/build/tmp/work/x86_64-linux/qtbase-native/5.7.1+gitAUTOINC+a55f36211e-r0/temp/log.do_compile.2214

ERROR: Task (/opt/petalinux/components/yocto/source/aarch64/layers/meta-qt5/recipes-qt/qt5/qtbase-native_git.bb:do_compile) failed with exit code '1'

 

I am using ubuntu 16.04 and have installed all the dependent packages on ug1144. For example, python, tofrodos, iproute, and so on.
A typical petalinux-build has also been successfully built.

0 Kudos
1 Solution

Accepted Solutions
Visitor geff_1
Visitor
847 Views
Registered: ‎05-07-2018

Re: Zynq UltraScale MPSoC Base TRD 2017.4 DM1

Jump to solution

Hi:

 

I found your problom is due to Internet bad condition. So I suggest you to move offline build mode. Reference flow:https://forums.xilinx.com/t5/Embedded-Linux/Doe-petalinux-builds-really-require-internet/td-p/846574.

 

Then the issue you encounter could be fixed.

 

But I found other problems I met when I build kernel. I will list following:(my petalinux version is 2018.2)

1. under component dir, device tree directory is missing.

    so you have manually open auto config setting->device tree autoconfig

2. when you package boot.bin, you have to include bitstream file, otherwise boot will stuck at kernel.

 

Hope it is helpful to you.

View solution in original post

4 Replies
Visitor geff_1
Visitor
820 Views
Registered: ‎05-07-2018

Re: Zynq UltraScale MPSoC Base TRD 2017.4 DM1

Jump to solution

I meet the same problem.

Do you fix it?

I check log, it seem petalinux cannot find source from git.

0 Kudos
Observer ain0102
Observer
793 Views
Registered: ‎02-06-2018

Re: Zynq UltraScale MPSoC Base TRD 2017.4 DM1

Jump to solution
I have not fixed it yet.
0 Kudos
Visitor geff_1
Visitor
848 Views
Registered: ‎05-07-2018

Re: Zynq UltraScale MPSoC Base TRD 2017.4 DM1

Jump to solution

Hi:

 

I found your problom is due to Internet bad condition. So I suggest you to move offline build mode. Reference flow:https://forums.xilinx.com/t5/Embedded-Linux/Doe-petalinux-builds-really-require-internet/td-p/846574.

 

Then the issue you encounter could be fixed.

 

But I found other problems I met when I build kernel. I will list following:(my petalinux version is 2018.2)

1. under component dir, device tree directory is missing.

    so you have manually open auto config setting->device tree autoconfig

2. when you package boot.bin, you have to include bitstream file, otherwise boot will stuck at kernel.

 

Hope it is helpful to you.

View solution in original post

Highlighted
Observer ain0102
Observer
762 Views
Registered: ‎02-06-2018

Re: Zynq UltraScale MPSoC Base TRD 2017.4 DM1

Jump to solution
Thank you so much for your help.
I'll try it.
0 Kudos