UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

Reply

Zynq second UART, no output to minicom

Accepted Solution Solved
Explorer
Posts: 111
Registered: ‎06-23-2013
Accepted Solution

Zynq second UART, no output to minicom

UART1 is working as ttyPS0 console on our custom board based on zc706.

Added UART0 to devicetree, /dev/ttyPS1 is there, also  /proc/interrupts 59 but there is no device name

 

 59:         53          0       GIC
 72:          0          0       GIC  f8003000.ps7-dma
 73:          0          0       GIC  f8003000.ps7-dma
 74:          0          0       GIC  f8003000.ps7-dma
 75:          0          0       GIC  f8003000.ps7-dma
 82:        807          0       GIC  xuartps

 

cat /proc/tty/driver/xuartps
serinfo:1.0 driver revision:
0: uart:xuartps mmio:0xE0001000 irq:82 tx:13435 rx:484 RTS|CTS|DTR|DSR|CD
1: uart:xuartps mmio:0xE0000000 irq:59 tx:3216 rx:0 CTS|DSR|CD

echo "hello to UART0" > /dev/ttyPS1

does not produce output to minicom.

 

Did I need to change .config ?

# CONFIG_DEBUG_ZYNQ_UART0 is not set
CONFIG_DEBUG_ZYNQ_UART1=y

 

 

dogbytes

Accepted Solutions
Explorer
Posts: 111
Registered: ‎06-23-2013

UART0, /dev/ttyPS1 at 9600 baud Re: RX=MIO 34 TX=MIO 35 Re: Zynq second UART, no output to minicom

Hurray for our oscilloscope, UART0,  /dev/ttyPS1 is running at 9600 baud.

Why by default would it not be like UART1, /dev/ttyPS0 console ?


One mystery solved and on to the next.

dogbytes

View solution in original post


All Replies
Xilinx Employee
Posts: 1,128
Registered: ‎07-01-2010

Re: Zynq second UART, no output to minicom

Hi,

 

I guess ZC706 , doesn't have an option to use 2 Uarts at a time as they have single Usb-Uart bridge.

I expect Uart1 to be working as the they are connected to the MIO 48 & 49 pins and connected mini USB.

What are the MIO pins connected to Uart 0 ? Do you have two uart options on board?

 

Please correct me if my understanding is wrong.

 

Regards,
Achutha

 

 

---------------------------------------------------------------------------------------------
Kindly note- Please mark the Answer as "Accept as solution" if information provided is helpful.

Give Kudos to a post which you think is helpful and reply oriented.
----------------------------------------------------------------------------------------
Explorer
Posts: 111
Registered: ‎06-23-2013

RX=MIO 34 TX=MIO 35 Re: Zynq second UART, no output to minicom

Dear Moderator,   Yes, we have two UART options on our custom board.  Does zc706 bring UART0 RX,TX out to pins ?

 

I'd like to know if Xilinx has tested UART0 as a second UART and is xilinx_uartps.c suitable driver  for it ?

It did not help when I changed xilinx_zynq_defconfig and rebuilt uImage with,

CONFIG_DEBUG_ZYNQ_UART0=y

 

The console on our custom board based on zc706 works as UART1, TX=MIO 48 and RX=MIO 49 to our USB adapter to minicom.

 

  Our custom board is using for UART0 RX=MIO 34  TX=MIO 35 does not output to minicom on the same

kind of USB adapter.  The UART0 RX and TX are brought out to a ribbon cable on our custom board as are UART1 RX,TX.

dogbytes
Explorer
Posts: 111
Registered: ‎06-23-2013

UART0, /dev/ttyPS1 at 9600 baud Re: RX=MIO 34 TX=MIO 35 Re: Zynq second UART, no output to minicom

Hurray for our oscilloscope, UART0,  /dev/ttyPS1 is running at 9600 baud.

Why by default would it not be like UART1, /dev/ttyPS0 console ?


One mystery solved and on to the next.

dogbytes
Scholar
Posts: 405
Registered: ‎05-28-2013

Re: UART0, /dev/ttyPS1 at 9600 baud Re: RX=MIO 34 TX=MIO 35 Re: Zynq second UART, no output to minicom

The speed of the console is determined by kernel boot parameters, typically: console=ttyPS0,115200

Other UARTs do not necessarily share the same speed. If you plan to run getty/login on the other uarts, then the speed is controlled by the getty program (check in /etc/inittab if you use a busybox/PetaLinux system). You can use "setserial" to change the speed.