UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Adventurer
Adventurer
3,132 Views
Registered: ‎05-01-2012

buildroot for Microblaze v2.0 toolchain

I'm trying to create a file system for a microblaze processor on the ML510 dev board using buildroot.  I downloaded the latest version of buildroot (2012.08) and went through the configuration.  I selected the external toolchain and gave it the path to my already installed v2.0 toolchain.  When I try to make, it stops almost right away with this error:

Checking external toolchain settings
Incorrect selection of the C library

I've tried changing from the Xilinx toolchain option to the custom one, and I've tried selecting the glibc and the uClibc, and they all give the same error.  Has anyone successfully used buildroot to make a filesystem with the v2.0 cross-compiler toolchain and can give me some pointers on what the error here is?

 

 

0 Kudos
1 Reply
Visitor wdwelch
Visitor
3,100 Views
Registered: ‎06-19-2009

Re: buildroot for Microblaze v2.0 toolchain

Greetings,

 

I did not use exactly the same toolchain as you, but I did run into the same problem.

 

The solution seems to be to select 'custom toolchain', instead of 'external toolchain'.  Then specify the path and prefix and all should be well.

 

By the way I had trouble matching up the correct toolchain with the correct kernel --- most things worked except the 'stat' syscall --  ls -ls /dev would not show the device nodes correctly.

 

But by using the recent 4.6.2 toolchain and the 3.5.0 kernel, buildroot 2012.08 is working much better.

 

William

 

0 Kudos