UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

Reply

can not install petalinux 2015.4

Accepted Solution Solved
Scholar
Posts: 1,180
Registered: ‎11-09-2013
Accepted Solution

can not install petalinux 2015.4

we had very little problems with petalinux releases until 2015.4

 

2015.4 just does not even install anymore...! What is happening?

 

/root/Downloads/petalinux-v2015.4-final-installer.run: line 131: /tmp/tmp.Cjtx97G1pV/petalinux-v2015.4-final/tools/common/petalinux/utils/petalinux-install: cannot execute binary file

 

and yes I have read the petalinux install guide, there is however only guide for 2014.2 version no newer version can be found.

 


Accepted Solutions
Moderator
Posts: 5,501
Registered: ‎08-01-2008

Re: can not install petalinux 2015.4

This error occurs when the Virtual machine is a 32-bit OS.

Petalinux only supports 64-bit hosts.
Thanks and Regards
Balkrishan
--------------------------------------------------------------------------------------------
Please mark the post as an answer "Accept as solution" in case it helped resolve your query.
Give kudos in case a post in case it guided to the solution.

View solution in original post


All Replies
Moderator
Posts: 5,501
Registered: ‎08-01-2008

Re: can not install petalinux 2015.4

This error occurs when the Virtual machine is a 32-bit OS.

Petalinux only supports 64-bit hosts.
Thanks and Regards
Balkrishan
--------------------------------------------------------------------------------------------
Please mark the post as an answer "Accept as solution" in case it helped resolve your query.
Give kudos in case a post in case it guided to the solution.
Scholar
Posts: 1,180
Registered: ‎11-09-2013

Re: can not install petalinux 2015.4

maybe it would be wise to write this in PETALINUX INSTALL DOCUMENT ??

 

2015.2 did work in 32 bit...