UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Explorer
Explorer
3,385 Views
Registered: ‎02-18-2014

can't install openssh conflicted package dropbear

Jump to solution

I've attempted to add openssh to my sd card build image with 2016.3 petalinux. However as soon as I enable the below features in petalinux-config -c rootfs it exits with a failure.

 

Filesystem Packages --->

   console/network --->

      openssh --->

         [*] openssh

         [*] openssh-ssh

 

error: Can't install openssh-7.1p2-r0@cortexa9hf_neon: conflicted package dropbear-2016.72-r0@cortexa9hf_neon is locked
ERROR: smart_get_pkgs_to_targetroot: Failed to generate the list of packages to install based on the selected packages.
make: *** [update_rootfs_config_pkgs] Error 255
ERROR: Failed to oldconfig linux/rootfs!
ERROR: Failed to configure subcomponent linux/rootfs for linux
ERROR: Failed to config subcomponents of linux!
ERROR: Failed to config component linux/rootfs

 

Ideas? This works just fine when im building a nand image with 2016.3

0 Kudos
1 Solution

Accepted Solutions
Moderator
Moderator
5,794 Views
Registered: ‎12-04-2016

Re: can't install openssh conflicted package dropbear

Jump to solution

Hi

 

De-select dropbear SSH rootfs package. Getting conflict

3 Replies
Moderator
Moderator
5,795 Views
Registered: ‎12-04-2016

Re: can't install openssh conflicted package dropbear

Jump to solution

Hi

 

De-select dropbear SSH rootfs package. Getting conflict

Explorer
Explorer
3,277 Views
Registered: ‎02-18-2014

Re: can't install openssh conflicted package dropbear

Jump to solution

Well that was simple, thanks for the help. That fixed it. Not sure why I haven't seen this conflict in the past.

0 Kudos
Explorer
Explorer
3,205 Views
Registered: ‎10-14-2015

Re: can't install openssh conflicted package dropbear

Jump to solution

in the past only a warning was raised, not an error

0 Kudos