cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
gsanson
Participant
Participant
8,408 Views
Registered: ‎04-13-2015

configure command fails when trying to rebuild qt soureces

Hi,

 

When I follow the steps to rebuikl the qt from sources in

http://www.wiki.xilinx.com/Zynq+Qt+and+Qwt+Base+Libraries-Build+Instructions

 

I get the following output when running the configure command

 

gsanson@ubuntu12:/opt/pkg/Qt/build/qt-everywhere-opensource-src-4.8.5$ ./configure -embedded arm -xplatform qws/linux-arm-gnueabi-g++ -little-endian -opensource -host-little-endian -confirm-license -nomake demos -nomake examples -prefix $ZYNQ_QT_INSTALL

This is the Qt for Embedded Linux Open Source Edition.

You are licensed to use this software under the terms of
the Lesser GNU General Public License (LGPL) versions 2.1.
You are also licensed to use this software under the terms of
the GNU General Public License (GPL) versions 3.

You have already accepted the terms of the  license.

Creating qmake. Please wait...
g++ -c -o project.o -pipe -m64 -DQMAKE_OPENSOURCE_EDITION -g -I. -Igenerators -Igenerators/unix -Igenerators/win32 -Igenerators/mac -Igenerators/symbian -Igenerators/integrity -I/opt/pkg/Qt/build/qt-everywhere-opensource-src-4.8.5/include -I/opt/pkg/Qt/build/qt-everywhere-opensource-src-4.8.5/include/QtCore -I/opt/pkg/Qt/build/qt-everywhere-opensource-src-4.8.5/src/corelib/global -I/opt/pkg/Qt/build/qt-everywhere-opensource-src-4.8.5/src/corelib/xml -I/opt/pkg/Qt/build/qt-everywhere-opensource-src-4.8.5/tools/shared -DQT_NO_PCRE -DQT_BUILD_QMAKE -DQT_BOOTSTRAPPED -DQLIBRARYINFO_EPOCROOT -DQT_NO_TEXTCODEC -DQT_NO_UNICODETABLES -DQT_NO_COMPONENT -DQT_NO_STL -DQT_NO_COMPRESS -I/opt/pkg/Qt/build/qt-everywhere-opensource-src-4.8.5/mkspecs/qws/linux-x86_64-g++ -DHAVE_QCONFIG_CPP -DQT_NO_THREAD -DQT_NO_QOBJECT -DQT_NO_GEOM_VARIANT -DQT_NO_DEPRECATED  project.cpp
g++: error: unrecognized command line option '-m64'
make: *** [project.o] Error 1
gsanson@ubuntu12:/opt/pkg/Qt/build/qt-everywhere-opensource-src-4.8.5$

 

Does anyone know what is happening and why? I get that this may be a 32/64 bit issue.

 

Dev Platform

Ubuntu 12.04 LTS 64bit

 

Thanks,

Gary

0 Kudos
4 Replies
radheys
Xilinx Employee
Xilinx Employee
8,389 Views
Registered: ‎02-20-2014

Hi ,

Please check if CROSS_COMPILE environment variable is set and cross-compiler is added to path.

bash> export CROSS_COMPILE=arm-xilinx-linux-gnueabi-
bash> export PATH=/path/to/cross/compiler/bin:$PATH
0 Kudos
gsanson
Participant
Participant
8,378 Views
Registered: ‎04-13-2015

Hi,

Thanks for the response

 

Yes I have doen that that set but that is what is confusing. I've got everything set as suggested or how I thought they should be based upon the AR

 

Here is the list of installed cros compilers under the /opt directory

 

./pkg/petalinux-v2014.4-final/tools/linux-i386/arm-xilinx-gnueabi
./pkg/petalinux-v2014.4-final/tools/linux-i386/arm-xilinx-linux-gnueabi
./pkg/petalinux-v2014.4-final/tools/linux-i386/arm-xilinx-linux-gnueabi/arm-xilinx-linux-gnueabi
./pkg/petalinux-v2014.4-final/tools/linux-i386/arm-xilinx-linux-gnueabi/arm-xilinx-linux-gnueabi/include/c++/4.8.3/arm-xilinx-linux-gnueabi
./pkg/petalinux-v2014.4-final/tools/linux-i386/arm-xilinx-linux-gnueabi/lib/gcc/arm-xilinx-linux-gnueabi
./pkg/petalinux-v2014.4-final/tools/linux-i386/arm-xilinx-linux-gnueabi/libexec/gcc/arm-xilinx-linux-gnueabi
./Xilinx/SDK/2014.4/gnu/arm/lin/arm-xilinx-linux-gnueabi
./Xilinx/SDK/2014.4/gnu/arm/lin/arm-xilinx-linux-gnueabi/include/c++/4.8.3/arm-xilinx-linux-gnueabi
./Xilinx/SDK/2014.4/gnu/arm/lin/lib/gcc/arm-xilinx-linux-gnueabi
./Xilinx/SDK/2014.4/gnu/arm/lin/share/doc/xilinx-arm-xilinx-linux-gnueabi
./Xilinx/SDK/2014.4/gnu/arm/lin/libexec/gcc/arm-xilinx-linux-gnueabi
./Xilinx/SDK/2014.4/gnu/arm/lin/i686-pc-linux-gnu/arm-xilinx-linux-gnueabi

 

Which one should be used?

 

 

And my envronment variable

CROSS_COMPILE=arm-xilinx-linux-gnueabi-

ARCH=arm

PETALINUX=/opt/pkg/petalinux-v2014.4-final

PATH=/opt/Xilinx/SDK/2014.4/gnu/arm/lin/arm-xilinx-linux-gnueabi/bin:/opt/Xilinx/SDK/2014.4/bin:/opt/Xilinx/Vivado/2014.4/bin:/usr/lib/lightdm/lightdm:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games:/opt/Xilinx/Vivado/2014.4/bin:/opt/Xilinx/SDK/2014.4/bin

PETALINUX_VER=2014.4

ZYNQ_TRD_HOME=/opt/pkg/rdf0286-zc702-zvik-base-trd-2014-4

ZYNQ_QT_BUILD=/opt/pkg/Qt/build

ZYNQ_QT_INSTALL=/opt/pkg/Qt/install

 

 

Any other ideas?

 

Thanks,

Gary

0 Kudos
radheys
Xilinx Employee
Xilinx Employee
8,334 Views
Registered: ‎02-20-2014

We can set crosscompiler path to either XSDK or Petalinux.


Looking in gcc documentation option  "-m64" generates code for a 32-bit or 64-bit environment.

Simply check if option (-m64)  is supported on host compiler.

<cross-compiler>-g++  -m64  hello.cpp

<cross-compiler>-g++  -m32  hello.cpp

 

 

-Radhey

0 Kudos
radheys
Xilinx Employee
Xilinx Employee
8,330 Views
Registered: ‎02-20-2014

To add:

Here is my G++ configuration.
linux-xlnx]$ g++ -v
Using built-in specs.
Target: x86_64-redhat-linux
Configured with: ../configure --prefix=/usr --mandir=/usr/share/man --infodir=/usr/share/info --enable-shared --enable-threads=posix --enable-checking=release --with-system-zlib --enable-__cxa_atexit --disable-libunwind-exceptions --enable-libgcj-multifile --enable-languages=c,c++,objc,obj-c++,java,fortran,ada --enable-java-awt=gtk --disable-dssi --disable-plugin --with-java-home=/usr/lib/jvm/java-1.4.2-gcj-1.4.2.0/jre --with-cpu=generic --host=x86_64-redhat-linux
Thread model: posix
gcc version 4.1.2 20080704 (Red Hat 4.1.2-54)

0 Kudos