UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
3,303 Views
Registered: ‎08-18-2014

ethernet disabled

Jump to solution

Hi:

I'm trying to debug my app with XSDK in petalinux 2015.04 qemu enviroment, but linux cannot find eth0.

boot information:

Configuring network interfaces... ifconfig: SIOCGIFFLAGS: No such device

with help of qemu document(see attachment), subsystems/linux/configs/device-tree/system_top.dts modified like this

 

&gem0 {
   phy-handle = <&phy0>;
   phy-mode = "rgmii-id";
   mdio {
	   #address-cells = <1>;
	   #size-cells = <0>;
	   phy0: phy@0 {
	      compatible = "marvell,88e1510";
	      device_type = "ethernet-phy";
	      reg = <0>;
	   };
	}; 
};

By using this command to check DTB:

 

../../build/linux/kernel/xlnx-3.19/scripts/dtc/dtc -I dtb -O dts -o system.dts system.dtb

system.dts indicates port disabled:

ethernet@e000b000 {
			compatible = "cdns,gem";
			reg = <0xe000b000 0x1000>;
			status = "disabled";
			interrupts = <0x0 0x16 0x4>;
			clocks = <0x1 0x1e 0x1 0x1e 0x1 0xd>;
			clock-names = "pclk", "hclk", "tx_clk";
			#address-cells = <0x1>;
			#size-cells = <0x0>;
			phy-handle = <0x4>;
			phy-mode = "rgmii-id";

			mdio {
				#address-cells = <0x1>;
				#size-cells = <0x0>;

				phy@0 {
					compatible = "marvell,88e1510";
					device_type = "ethernet-phy";
					reg = <0x0>;
					linux,phandle = <0x4>;
					phandle = <0x4>;
				};
			};
		};

The same operation work well at ptlnx 2015.02, status is okay.

 

Any help is welcome...

0 Kudos
1 Solution

Accepted Solutions
5,329 Views
Registered: ‎08-18-2014

Re: ethernet disabled

Jump to solution

Solution:

Modifiy subsystems/linux/configs/device-tree/zynq-7000.dtsi as follows:

         gem0: ethernet@e000b000 {
             compatible = "cdns,gem";
             reg = <0xe000b000 0x1000>;
             status = "okay";
             interrupts = <0 22 4>;
             clocks = <&clkc 30>, <&clkc 30>, <&clkc 13>;
             clock-names = "pclk", "hclk", "tx_clk";
             #address-cells = <1>;
             #size-cells = <0>;
         };

But petalinux 2015.02 do not need this step. Cannot tell why.

 

View solution in original post

0 Kudos
1 Reply
5,330 Views
Registered: ‎08-18-2014

Re: ethernet disabled

Jump to solution

Solution:

Modifiy subsystems/linux/configs/device-tree/zynq-7000.dtsi as follows:

         gem0: ethernet@e000b000 {
             compatible = "cdns,gem";
             reg = <0xe000b000 0x1000>;
             status = "okay";
             interrupts = <0 22 4>;
             clocks = <&clkc 30>, <&clkc 30>, <&clkc 13>;
             clock-names = "pclk", "hclk", "tx_clk";
             #address-cells = <1>;
             #size-cells = <0>;
         };

But petalinux 2015.02 do not need this step. Cannot tell why.

 

View solution in original post

0 Kudos