UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

Reply

[kernel boot problem] petalinux 2013.10 with 3.14 kernel

Highlighted
Visitor
Posts: 6
Registered: ‎06-09-2014

[kernel boot problem] petalinux 2013.10 with 3.14 kernel

Guys, I try to port Zynq base TRD to my zc706. I want to use 3.14 kernel instead of 3.12 listed in manual as 3.14 is provided with petalinux 2014.2 and can be easily downloaded. Unfortunately, I could not yet download xilinx kernel repo.

One nice guy from Xilinx said that I should use a diffrent device tree for 3.14 kernel comparing to 3.8. We have tried to download device trees from Xilinx github repo and uboot worked fine but when we booted kernel we get a long log looking successful but we don't have a login console.

Here is the log:

Gem.e000b000 Waiting for PHY auto negotiation to complete...... done
BOOTP broadcast 1
DHCP client bound to address 192.168.1.14
Hit any key to stop autoboot:  0 
U-Boot-PetaLinux> Uncompressing Linux... done, booting the kernel.
Booting Linux on physical CPU 0x0
Linux version 3.14.2 (i.panchenko@panchenko-u) (gcc version 4.7.3 (Sourcery CodeBench Lite 2013.05-40) ) #2 SMP PREEMPT Wed Jul 16 19:13:03 MSK 2014
CPU: ARMv7 Processor [413fc090] revision 0 (ARMv7), cr=18c5387d
CPU: PIPT / VIPT nonaliasing data cache, VIPT aliasing instruction cache
Machine model: Xilinx Zynq
bootconsole [earlycon0] enabled
Memory policy: Data cache writealloc
PERCPU: Embedded 7 pages/cpu @eefde000 s7232 r8192 d13248 u32768
Built 1 zonelists in Zone order, mobility grouping on.  Total pages: 260624
Kernel command line: console=ttyPS0,115200 root=/dev/ram rw earlyprintk
PID hash table entries: 4096 (order: 2, 16384 bytes)
Dentry cache hash table entries: 131072 (order: 7, 524288 bytes)
Inode-cache hash table entries: 65536 (order: 6, 262144 bytes)
Memory: 1031248K/1048576K available (3583K kernel code, 189K rwdata, 1620K rodata, 2651K init, 131K bss, 17328K reserved, 270336K highmem)
Virtual kernel memory layout:
    vector  : 0xffff0000 - 0xffff1000   (   4 kB)
    fixmap  : 0xfff00000 - 0xfffe0000   ( 896 kB)
    vmalloc : 0xf0000000 - 0xff000000   ( 240 MB)
    lowmem  : 0xc0000000 - 0xef800000   ( 760 MB)
    pkmap   : 0xbfe00000 - 0xc0000000   (   2 MB)
    modules : 0xbf000000 - 0xbfe00000   (  14 MB)
      .text : 0xc0008000 - 0xc051d004   (5205 kB)
      .init : 0xc051e000 - 0xc07b4c40   (2652 kB)
      .data : 0xc07b6000 - 0xc07e57e0   ( 190 kB)
       .bss : 0xc07e57ec - 0xc0806450   ( 132 kB)
Preemptible hierarchical RCU implementation.
NR_IRQS:16 nr_irqs:16 16
ps7-slcr mapped to f0004000
zynq_clock_init: clkc starts at f0004100
Zynq clock init
sched_clock: 64 bits at 333MHz, resolution 3ns, wraps every 3298534883328ns
ps7-ttc #0 at f0006000, irq=43
Console: colour dummy device 80x30
Calibrating delay loop... 1332.01 BogoMIPS (lpj=6660096)
pid_max: default: 32768 minimum: 301
Mount-cache hash table entries: 2048 (order: 1, 8192 bytes)
Mountpoint-cache hash table entries: 2048 (order: 1, 8192 bytes)
CPU: Testing write buffer coherency: ok
Setting up static identity map for 0x363678 - 0x3636ac
L310 cache controller enabled
l2x0: 8 ways, CACHE_ID 0x410000c8, AUX_CTRL 0x72460000, Cache size: 512 kB
CPU1: Booted secondary processor
Brought up 2 CPUs
SMP: Total of 2 processors activated.
CPU: All CPU(s) started in SVC mode.
devtmpfs: initialized
VFP support v0.3: implementor 41 architecture 3 part 30 variant 9 rev 4
NET: Registered protocol family 16
DMA: preallocated 256 KiB pool for atomic coherent allocations
syscon f8000000.ps7-slcr: regmap [mem 0xf8000000-0xf8000fff] registered
zynq-ocm f800c000.ps7-ocmc: ZYNQ OCM pool: 256 KiB @ 0xf0080000
bio: create slab <bio-0> at 0
SCSI subsystem initialized
usbcore: registered new interface driver usbfs
usbcore: registered new interface driver hub
usbcore: registered new device driver usb
Switched to clocksource arm_global_timer
NET: Registered protocol family 2
TCP established hash table entries: 8192 (order: 3, 32768 bytes)
TCP bind hash table entries: 8192 (order: 4, 65536 bytes)
TCP: Hash tables configured (established 8192 bind 8192)
TCP: reno registered
UDP hash table entries: 512 (order: 2, 16384 bytes)
UDP-Lite hash table entries: 512 (order: 2, 16384 bytes)
NET: Registered protocol family 1
RPC: Registered named UNIX socket transport module.
RPC: Registered udp transport module.
RPC: Registered tcp transport module.
RPC: Registered tcp NFSv4.1 backchannel transport module.
futex hash table entries: 512 (order: 3, 32768 bytes)
bounce pool size: 64 pages
jffs2: version 2.2. (NAND) © 2001-2006 Red Hat, Inc.
msgmni has been set to 1486
Block layer SCSI generic (bsg) driver version 0.4 loaded (major 253)
io scheduler noop registered
io scheduler deadline registered
io scheduler cfq registered (default)
xuartps e0001000.serial: aper_clk clock not found.
xuartps: probe of e0001000.serial failed with error -2
xdevcfg f8007000.ps7-dev-cfg: ioremap 0xf8007000 to f006a000
st: Version 20101219, fixed bufsize 32768, s/g segs 256
osst :I: Tape driver with OnStream support version 0.99.4
osst :I: $Id: osst.c,v 1.73 2005/01/01 21:13:34 wriede Exp $
SCSI Media Changer driver v0.25 
libphy: XEMACPS mii bus: probed
xemacps e000b000.ps7-ethernet: pdev->id -1, baseaddr 0xe000b000, irq 54
ehci_hcd: USB 2.0 'Enhanced' Host Controller (EHCI) Driver
ULPI transceiver vendor/product ID 0x0424/0x0007
Found SMSC USB3320 ULPI transceiver.
ULPI integrity check: passed.
usbcore: registered new interface driver usb-storage
i2c /dev entries driver
sdhci: Secure Digital Host Controller Interface driver
sdhci: Copyright(c) Pierre Ossman
sdhci-pltfm: SDHCI platform and OF driver helper
usbcore: registered new interface driver usbhid
usbhid: USB HID core driver
TCP: cubic registered
NET: Registered protocol family 10
sit: IPv6 over IPv4 tunneling driver
NET: Registered protocol family 17
Registering SWP/SWPB emulation handler
bootconsole [earlycon0] disabled


 We have tried both device trees for zc702 and zc706 with no successful kernel build.

 

Contributor
Posts: 23
Registered: ‎01-28-2014

Re: [kernel boot problem] petalinux 2013.10 with 3.14 kernel

This looks like either a device tree problem or a kernel problem. Since you download the device tree from the repo, I would guess that there is possibly a kernel driver problem.

In your log, the xuart drivers don't seem to be compiling correctly. See:
xuartps e0001000.serial: aper_clk clock not found.
xuartps: probe of e0001000.serial failed with error -2

Which is possibly why the the terminal stops printing. Try modifying the linux kernel and make sure that the necessary drivers are installed.

Assuming that the correct drivers were selected then it could possibly also be your compiler. Check that you use the correct cross-compiler toolchain. The compiler should be able to recognize "aper_clk" (or at least realize that it's deprecated).
Adventurer
Posts: 98
Registered: ‎10-28-2007

Re: [kernel boot problem] petalinux 2013.10 with 3.14 kernel

The DTS needs to be modified to match the updated kernel.  The aper_clk has been deprecated.  Look at the following commit: