UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Adventurer
Adventurer
1,696 Views
Registered: ‎07-08-2016

kernel panic on file system mount --- devtmpfs: error mounting -2

I am trying to get embedded linux up and running on zedboard (following this tutorial), and have successfully built everything and am able to boot into the U-boot command prompt.

 

However, when I attempt to boot into Linux, I get a kernel panic, with the following message:

 

IP-Config: Complete:
     device=eth0, hwaddr=fe:ed:de:ad:be:ef, ipaddr=129.170.68.162, mask=255.255.248.0, gw=129.170.64.1
     host=dhcp-129-170-68-162, domain=thayer.dartmouth.edu, nis-domain=(none)
     bootserver=129.170.64.49, rootserver=129.170.64.49, rootpath=     nameserver0=129.170.255.13
EXT4-fs (mmcblk0p2): mounted filesystem with ordered data mode. Opts: (null)
VFS: Mounted root (ext4 filesystem) on device 179:2.
devtmpfs: error mounting -2
Freeing unused kernel memory: 1024K (c0800000 - c0900000)
Kernel panic - not syncing: No working init found.  Try passing init= option to kernel. See Linux Documentation/init.txt for guidance.
CPU1: stopping
CPU: 1 PID: 0 Comm: swapper/1 Not tainted 4.6.0-xilinx #1
Hardware name: Xilinx Zynq Platform
[<c010e318>] (unwind_backtrace) from [<c010a508>] (show_stack+0x10/0x14)
[<c010a508>] (show_stack) from [<c02b3604>] (dump_stack+0x80/0xa0)
[<c02b3604>] (dump_stack) from [<c010ca24>] (ipi_cpu_stop+0x3c/0x70)
[<c010ca24>] (ipi_cpu_stop) from [<c010d294>] (handle_IPI+0x64/0x84)
[<c010d294>] (handle_IPI) from [<c01013e4>] (gic_handle_irq+0x74/0x90)
[<c01013e4>] (gic_handle_irq) from [<c010af14>] (__irq_svc+0x54/0x90)
Exception stack(0xde46ff70 to 0xde46ffb8)
ff60:                                     00000000 00000002 c08391c0 debde1c0
ff80: 00000000 debdd5c0 0c802108 00000002 0bed4ebf 00000002 00000000 00000000
ffa0: 00000008 de46ffc0 c0471f20 c0471f44 60000013 ffffffff
[<c010af14>] (__irq_svc) from [<c0471f44>] (cpuidle_enter_state+0xe4/0x1c0)
[<c0471f44>] (cpuidle_enter_state) from [<c014a470>] (cpu_startup_entry+0x184/0x1d0)
[<c014a470>] (cpu_startup_entry) from [<0010148c>] (0x10148c)
---[ end Kernel panic - not syncing: No working init found.  Try passing init= option to kernel. See Linux Documentation/init.txt for guidance.
I think the key issue is the error: 
devtmpfs: error mounting -2

Does anyone know why it might not be able to mount the filesystem? What information can I give in order to further debug this issue (I don't even know where to start). Are there any log files that would be helpful in diagnosing the issue? 

 

I am running Vivado 2016.4 on Ubuntu 16.04 with 32G RAM

 

Best,

 

Brett

0 Kudos