cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
jpbb
Participant
Participant
2,368 Views
Registered: ‎03-26-2018

modprobe not working properly on 2017.4

Jump to solution

Hi,

I am currently working on the zcu102 board. I generated a custom Linux module with "petalinux-create -t modules --names fpga --enable". The module fpga.ko is built and placed into /lib/module/4.9.0-xilinx-v20117.4/extra

 

It is started at start-up when booting the kernel. I guess it runs insmod. It is possible to unload the module via rmmod..... But when trying to "modprobe" the module, it returns that the module cannot be found in modules.dep.  The module IS in modules.dep and has no depedency (extra/fpga.ko:     )

 

I tried different things:

  1. Regenerate modules.dep (depmod -a)     No SUCCESS
  2. move fpga.ko into .../kernel/drivers/misc and regenerate   No SUCCESS
  3. force modprobe via -f , option not supported.

Could you check  that this functionality is working for you. Is there any problem with 2017.4?

Thanks in advance for your help!

JP

 

 

Tags (2)
0 Kudos
1 Solution

Accepted Solutions
jpbb
Participant
Participant
2,642 Views
Registered: ‎03-26-2018
well.... I checked again and it works as insmod (you have to type "modprobe fpga"
regards JP

View solution in original post

0 Kudos
3 Replies
trigger
Voyager
Voyager
2,360 Views
Registered: ‎09-14-2016

Hi @jpbb,

Why you don't use insmod cmd to load like at boot?

Cheers,
Trigger

0 Kudos
jpbb
Participant
Participant
2,346 Views
Registered: ‎03-26-2018

I unsderstood that "insmod" is just loading the module. Modprobe is loading +initializing the module.

Insmod does not run the probe function in the driver... and it is what I wanted to do

Regards

JP

0 Kudos
jpbb
Participant
Participant
2,643 Views
Registered: ‎03-26-2018
well.... I checked again and it works as insmod (you have to type "modprobe fpga"
regards JP

View solution in original post

0 Kudos