cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
betanken
Adventurer
Adventurer
1,554 Views
Registered: ‎08-22-2018

network settings of ubuntu rootfs on petalinux

Jump to solution

Hi all

 

I'm using ubuntu rootfs on petalinux now. I have tried to use $apt-get update, but its failed.

Here the errors:

===================================================================================================

All packages are up to date.
W: Failed to fetch http://ports.ubuntu.com/ubuntu-ports/dists/xenial/InRelease  Temporary failure resolving 'ports.ubuntu.com'
W: Failed to fetch http://ports.ubuntu.com/ubuntu-ports/dists/xenial-updates/InRelease  Temporary failure resolving 'ports.ubuntu.com'
W: Failed to fetch http://ports.ubuntu.com/ubuntu-ports/dists/xenial-security/InRelease  Temporary failure resolving 'ports.ubuntu.com'
W: Some index files failed to download. They have been ignored, or old ones used instead

===================================================================================================

 

Maybe I should use other sources instead http://ports.ubuntu.com/ubuntu-ports/ in etc/apt/sources.list?

 

Thanks a lot for help

 

Holzmann

0 Kudos
1 Solution

Accepted Solutions
deville
Explorer
Explorer
1,495 Views
Registered: ‎09-28-2018

Hi Betanken, 

 

If your company has a DNS server running, chances are great you are behind a firewall. 

 

Look at this link

https://help.ubuntu.com/community/AptGet/Howto

 

and go to the section: Setting up apt-get to use a proxy

View solution in original post

0 Kudos
9 Replies
trigger
Voyager
Voyager
1,547 Views
Registered: ‎09-14-2016
0 Kudos
betanken
Adventurer
Adventurer
1,544 Views
Registered: ‎08-22-2018

Hi @trigger

 

Thanks for reply.

 

I have checked it, it doesn't work for me....

0 Kudos
trigger
Voyager
Voyager
1,541 Views
Registered: ‎09-14-2016

Does adding nameserver 8.8.8.8 (Google's DNS server) to a new line on /etc/resolv.conf have any effect?

 

[EDIT]: probably need also:

 

sudo service resolvconf restart

Cheers,

Trigger

0 Kudos
betanken
Adventurer
Adventurer
1,535 Views
Registered: ‎08-22-2018

Our company has DNS server, and I don't think I need to add google DNS server in it....

 

On /etc/resolv.conf I can see nameserver of our company

0 Kudos
trigger
Voyager
Voyager
1,508 Views
Registered: ‎09-14-2016
@betanken are you able to ping an external server ?

Because of in your log you have only warnings no errors ...
0 Kudos
deville
Explorer
Explorer
1,496 Views
Registered: ‎09-28-2018

Hi Betanken, 

 

If your company has a DNS server running, chances are great you are behind a firewall. 

 

Look at this link

https://help.ubuntu.com/community/AptGet/Howto

 

and go to the section: Setting up apt-get to use a proxy

View solution in original post

0 Kudos
deville
Explorer
Explorer
1,474 Views
Registered: ‎09-28-2018

You can do some additional test to see if your DNS server is working

 

$ nslookup ports.ubuntu.com

 

it should give you 91.189.88.150 as an address

 

next, try to ping to the server 

 

$ ping 91.189.88.150

or

$ ping ports.ubuntu.com

 

If you are able to get a return message, you should look at your proxy settings. ( or ask your administrator ) otherwise it is likely your network ( hard- or software ) is malfunctioning.

 

 

0 Kudos
betanken
Adventurer
Adventurer
1,464 Views
Registered: ‎08-22-2018

Hallo @deville

 

Yes you are right. I checked the internal data-sheet of network settings and resolved the issue. Thanks

0 Kudos
betanken
Adventurer
Adventurer
1,463 Views
Registered: ‎08-22-2018

@trigger

 

I solved the problem, thanks.

0 Kudos