UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Visitor fk5747
Visitor
23,116 Views

nfs mount problem on microblaze

Jump to solution

Hi

I run main line linux on my spartan3e board, on microblaze. I can ping from my computer to the board and back the other way. now I want to transfer my file to the board using NFS. I run NFS server on my computer correctly and I enter the following command:

# mount 192.168.100.110:/home/kalantari/myfile.c /mnt -o tcp

but I get this error:

svc: failed to register lockdv1 RPC service (errno 111).
lockd_up: makesock failed, error=-111
mount: mounting 192.168.100.110:/home/sadri/kalantari/a on /mnt failed: Connection refused

what is wrong? How can I fix it?

I also want to mount my root file system via NSF. can I do this?

0 Kudos
1 Solution

Accepted Solutions
Xilinx Employee
Xilinx Employee
31,452 Views

Re: nfs mount problem on microblaze

Jump to solution

If you're using one our our ramdisks, then you need to use some options on the command since it's a basic busybox filesystem.

 

mount -o port=2049,nolock,proto=tcp and then the normal stuff like ip and path after that.

 

There's some processes that are not running on a busybox filesystem that are needed if you don't specify these options.

 

Hope that helps.

0 Kudos
9 Replies
Visitor fk5747
Visitor
23,115 Views

Re: nfs mount problem on microblaze

Jump to solution

I also add that I can mount my file from other computers so I think there is a problem with the linux running on the board.

0 Kudos
Xilinx Employee
Xilinx Employee
23,104 Views

Re: nfs mount problem on microblaze

Jump to solution

I think your command line is wrong. You're trying to mount a .c file as a file system. Can you try this one and let me know how it looks?

 

mount -t nfs 192.168.100.110:/home/kalantari/ /mnt 

 

I'm assuming that you've compiled NFS support into the kernel.

0 Kudos
Xilinx Employee
Xilinx Employee
23,100 Views

Re: nfs mount problem on microblaze

Jump to solution

Also, yes, you can mount your root file system as NFS. There are a lot of tutorials out there on Google, but this is the one I've got bookmarked:

 

http://www.faqs.org/docs/Linux-mini/NFS-Root.html

 

It's a little old, but the information is still essentially correct.

0 Kudos
Xilinx Employee
Xilinx Employee
31,453 Views

Re: nfs mount problem on microblaze

Jump to solution

If you're using one our our ramdisks, then you need to use some options on the command since it's a basic busybox filesystem.

 

mount -o port=2049,nolock,proto=tcp and then the normal stuff like ip and path after that.

 

There's some processes that are not running on a busybox filesystem that are needed if you don't specify these options.

 

Hope that helps.

0 Kudos
Visitor fk5747
Visitor
23,092 Views

Re: nfs mount problem on microblaze

Jump to solution

thanks for your answers!

 

I am using initramfs_complete.cpio.gz.

I enter this command and I get the same error:

    # mount -t nfs 192.168.100.110:/home/kalantari /mnt

 

But when I try this command ....

   # mount -o port=2049,nolock,proto=tcp -t nfs 192.168.100.110:/home/kalantari  /mnt

 

Wow! It works! thanks a lot, you save my life ;)

 

0 Kudos
Visitor fk5747
Visitor
23,086 Views

Re: nfs mount problem on microblaze

Jump to solution

again thanks but I have another question. I have mounted rootfs via NFS on PowerPC before. If I want to do it on microblaze is it enough to write bootargs like this :

 

bootargs="console=ttyUL0,115200 root=/dev/nfs nfsroot=192.168.100.110:/home/sadri/a ,tcp ip=192.168.100.195 rw"

 

as I test this, it does not work. should I add some other parameters to bootargs?

0 Kudos
Xilinx Employee
Xilinx Employee
23,070 Views

Re: nfs mount problem on microblaze

Jump to solution

Yes it's the same as powerpc with the command line for nfs.  Maybe you don't have the kernel configuration right as you need to enable nfs root.

 

Thanks.

0 Kudos
Visitor gutolima11
Visitor
22,813 Views

Re: nfs mount problem on microblaze

Jump to solution

  Hi folks,

 

  I'm also having trouble with nfs root mounting. I'm using a Digilent Atlys Board (Spartan6 LX45) connected directly to my PC, an AXI Microblaze project (Little Endian), and the initramfs_minimal_le file.

 

  My guess is that the problem lies in the IP Config process during kernel initialization due to the message "IP-Config: Cannot add default route (-101)" . Also it seems awkward that the ethernet goes down and up during kernel initialization, which I suppose to be due to an MDIO reset. Here is my log. Any ideas of what might be wrong?

 

  Best Regards,

 

Gustavo Lima

 

 

 

 

early_printk_console is enabled at 0x40600000
Ramdisk addr 0x00000003, Compiled-in FDT at 0xc02aa400
Linux version 3.0.0+ (root@i7-linux.avanttel) (gcc version 4.1.2) #8 Fri Dec 16 17:30:03 BRST 2011
setup_cpuinfo: initialising
setup_cpuinfo: No PVR support. Using static CPU info from FDT
cache: wt_msr_noirq
setup_memory: max_mapnr: 0x8000
setup_memory: min_low_pfn: 0xc0000
setup_memory: max_low_pfn: 0xc8000
On node 0 totalpages: 32768
free_area_init_node: node 0, pgdat c034f47c, node_mem_map c039e000
  Normal zone: 256 pages used for memmap
  Normal zone: 0 pages reserved
  Normal zone: 32512 pages, LIFO batch:7
pcpu-alloc: s0 r0 d32768 u32768 alloc=1*32768
pcpu-alloc: [0] 0 
Built 1 zonelists in Zone order, mobility grouping on.  Total pages: 32512
Kernel command line: console=ttyUL0 ip=192.168.0.11:192.168.0.20:192.168.0.255:255.255.255.0::eth0:off root=/dev/nfs rw nfsroot=/opt/Embedded_Linux/embedded_xilinx/initramfs_minimal_le,tcp,nolock nfsrootdebug
PID hash table entries: 512 (order: -1, 2048 bytes)
Dentry cache hash table entries: 16384 (order: 4, 65536 bytes)
Inode-cache hash table entries: 8192 (order: 3, 32768 bytes)
Memory: 126072k/131072k available
NR_IRQS:32
xlnx,xps-intc-1.00.a #0 at 0xc8000000, num_irq=3, edge=0x6
xlnx,xps-timer-1.00.a #0 at 0xc8002000, irq=0
microblaze_timer_set_mode: shutdown
microblaze_timer_set_mode: periodic
Calibrating delay loop... 36.03 BogoMIPS (lpj=72064)
pid_max: default: 32768 minimum: 301
Mount-cache hash table entries: 512
devtmpfs: initialized
NET: Registered protocol family 16
bio: create slab <bio-0> at 0
XGpio: /axi@0/gpio@40040000: registered
XGpio: /axi@0/gpio@40020000: registered
XGpio: /axi@0/gpio@40000000: registered
Switching to clocksource microblaze_clocksource
microblaze_timer_set_mode: oneshot
Switched to NOHz mode on CPU #0
NET: Registered protocol family 2
IP route cache hash table entries: 1024 (order: 0, 4096 bytes)
TCP established hash table entries: 4096 (order: 3, 32768 bytes)
TCP bind hash table entries: 4096 (order: 2, 16384 bytes)
TCP: Hash tables configured (established 4096 bind 4096)
TCP reno registered
UDP hash table entries: 256 (order: 0, 4096 bytes)
UDP-Lite hash table entries: 256 (order: 0, 4096 bytes)
RPC: Registered named UNIX socket transport module.
RPC: Registered udp transport module.
RPC: Registered tcp transport module.
RPC: Registered tcp NFSv4.1 backchannel transport module.
Skipping unavailable RESET gpio -2 (reset)
GPIO pin is already allocated
nfs4filelayout_init: NFSv4 File Layout Driver Registering...
msgmni has been set to 246
Block layer SCSI generic (bsg) driver version 0.4 loaded (major 254)
io scheduler noop registered
io scheduler deadline registered
io scheduler cfq registered (default)
40600000.serial: ttyUL0 at MMIO 0x40600000 (irq = 2) is a uartlite
console [ttyUL0] enabled
brd: module loaded
loop: module loaded
Generic platform RAM MTD, (c) 2004 Simtec Electronics
xilinx_emaclite 40e00000.ethernet: Device Tree Probing
Xilinx Emaclite MDIO: probed
xilinx_emaclite 40e00000.ethernet: MAC address is now 00:0a:35:16:9e:00
xilinx_emaclite 40e00000.ethernet: Xilinx EmacLite at 0x40E00000 mapped to 0xC8080000, irq=1
TCP cubic registered
IP-Config: Cannot add default route (-101).
Root-NFS: nfsroot=/opt/Embedded_Linux/embedded_xilinx/initramfs_minimal_le,tcp,nolock
NFS: nfs mount opts='vers=2,udp,rsize=4096,wsize=4096,tcp,nolock,nolock,addr=192.168.0.20'
NFS:   parsing nfs mount option 'vers=2'
NFS:   parsing nfs mount option 'udp'
NFS:   parsing nfs mount option 'rsize=4096'
NFS:   parsing nfs mount option 'wsize=4096'
NFS:   parsing nfs mount option 'tcp'
NFS:   parsing nfs mount option 'nolock'
NFS:   parsing nfs mount option 'nolock'
NFS:   parsing nfs mount option 'addr=192.168.0.20'
NFS: MNTPATH: '/opt/Embedded_Linux/embedded_xilinx/initramfs_minimal_le'
NFS: sending MNT request for 192.168.0.20:/opt/Embedded_Linux/embedded_xilinx/initramfs_minimal_le
PHY: c034b7a0:07 - Link is Down
PHY: c034b7a0:07 - Link is Up - 100/Full
NFS: failed to create MNT RPC client, status=-113
NFS: unable to mount server 192.168.0.20, error -113
VFS: Unable to mount root fs via NFS, trying floppy.
VFS: Cannot open root device "nfs" or unknown-block(2,0)
Please append a correct "root=" boot option; here are the available partitions:
Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(2,0)

 

 

 

 

0 Kudos
Newbie jamesco
Newbie
13,184 Views

Re: nfs mount problem on microblaze

Jump to solution

I had that error also. On a 64bit redhat flavoured box.
I needed to add “port=2049,nolock,proto=tcp” to options for nfs mounts in /etc/mtab

I think it is due to mounting from ipv4 nfs to an ipv6 box.

 

0 Kudos