cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
it
Visitor
Visitor
662 Views
Registered: ‎05-19-2020

no login prompt after Petalinux 2020.1 boot on ultra96v2 board

Hi,

I am evaluating Petalinux 2020.1 on ultra96v2 board.  There is no login prompt after Petalinux boot.

Warning message appears during boot “Warning: unable to open an initial console”.

How I build the project:

  • Build project in Vivado 2020.1 and exported XSA file
  • Created new petalinux project from template - "petalinux-create --type project --template zynqMP –name u96_2020_1"
  • Loaded hardware configuration - “petalinux-config --get-hw-description=./
  • Changed the following settings in petalinux-config utility:
    1. Subsystem AUTO Hardware Settings -> Memory Settings -> System Memory Size --- 0x6FFFFFFF
    2. Subsystem AUTO Hardware Settings -> Serial Settings --- All set to psu_uart_1
    3. Image Packaging Configuration -> Root File System Type --- EXT4
    4. Firmware Version Configuration -> Host Name – U96
  • Updated the system-user.dtsi (file is attached)

chosen {

    bootargs = "earlycon console=ttyPS0,115200 clk_ignore_unused root=/dev/mmcblk0p2 rw rootwait cma=512M";

};

aliases {

    serial0 = "/amba/serial@ff010000";

};

  • Build project using “petalinux-build”
  • Created boot files using “petalinux-package --boot --fsbl zynqmp_fsbl.elf --fpga system.bit --pmufw pmufw.elf --atf bl31.elf --u-boot u-boot.elf
  • Copied boot files and the root file system to SD card
  • Inserted SD card into ultra96v2 board
  • Turn on the power

 

Device tree and boot log files are attached.

 

Any suggestions would be greatly appreciated!             

Tags (1)
0 Kudos
2 Replies
kawazome
Adventurer
Adventurer
640 Views
Registered: ‎04-02-2014

 

I had a similar issue with linux-xlnx v2020.1.

I fixed this by fixing drivers/tty/serial/xilinx_uartps.c. as shown here.

Re: "Warning: unable to open an initial console" Under Petalinux 2020.1 with Picozed SOM 

it
Visitor
Visitor
589 Views
Registered: ‎05-19-2020

I updated xilinx_uartps.c, like you suggest

It boots now and login prompt appears.

Thank you

0 Kudos