UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Visitor 070411209
Visitor
841 Views
Registered: ‎09-01-2012

petalinux 2017.4 petalinux-build error

 

when run petalinux-build build the system, there have error message. here is part of the message:

 

 

WARNING: petalinux-user-image-1.0-r0 do_rootfs: log_check: There were error messages in the logfile
WARNING: petalinux-user-image-1.0-r0 do_rootfs: log_check: Matched keyword: [ERR]


ERROR: petalinux-user-image-1.0-r0 do_rootfs: 
ERROR: ld.so: object 'libpseudo.so' from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS64): ignored.
DEBUG: Shell function set_user_group finished
NOTE: Executing write_image_manifest ...
DEBUG: Executing python function write_image_manifest
DEBUG: Python function write_image_manifest finished

ERROR: petalinux-user-image-1.0-r0 do_rootfs: Function failed: do_rootfs
ERROR: Logfile of failure stored in: /home/one/xilinx/myPetalinux/ax7010_ov5640/build/tmp/work/plnx_arm-xilinx-linux-gnueabi/petalinux-user-image/1.0-r0/temp/log.do_rootfs.14231
ERROR: Task 9 (/home/one/xilinx/myPetalinux/ax7010_ov5640/project-spec/meta-plnx-generated/recipes-core/images/petalinux-user-image.bb, do_rootfs) failed with exit code '1'
NOTE: Tasks Summary: Attempted 1790 tasks of which 1789 didn't need to be rerun and 1 failed.

 

QQ图片20181019095649.png

 

i have find some topic ,but didnot passed.

 

thanks.

 

0 Kudos
2 Replies
Moderator
Moderator
787 Views
Registered: ‎12-04-2016

Re: petalinux 2017.4 petalinux-build error

Hi

 

Please make sure you have followed the installation requirements as per UG1144 guide while installing petalinux

https://www.xilinx.com/support/documentation/sw_manuals/xilinx2018_1/ug1144-petalinux-tools-reference-guide.pdf

 

 

Best Regards

Shabbir

0 Kudos
Highlighted
Observer jorisbolsens
Observer
776 Views
Registered: ‎10-02-2018

Re: petalinux 2017.4 petalinux-build error


@shabbirk wrote:

 

Please make sure you have followed the installation requirements as per UG1144 guide while installing petalinux

https://www.xilinx.com/support/documentation/sw_manuals/xilinx2018_1/ug1144-petalinux-tools-reference-guide.pdf

 


in addition to this, i found that libgtk2.0-dev was also required, I ran into a similar issue and just installing that solved it.

0 Kudos