cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
annamol
Contributor
Contributor
561 Views
Registered: ‎04-18-2017

petalinux 2018.1 and qt for ZC702

Hi,

Is there any document which gives details about using qt in petalinux and building GUI using that for petalinux 2018.1?  is there any specific version which needs to be used along with petalinux 2018.1? We have downloaded source code for 5.9.7 and qt creator is installed. but our qt-source compilation fails. We have tried the steps mentioned in AR59172  and  https://xilinx-wiki.atlassian.net/wiki/spaces/A/pages/18842110/Qt+Qwt+Build+Instructions+Qt+5.4.2+Qwt+6.1.2.    

But no change with qt source versions 4.8.5 and even 5.9.7.  With 4.8.5 version, ./configure ran but make was keeping on failing with multiple errors. We had added -no-pch in the ./configure command , but there was a javascript compilation error saying std::tr1{} undefined.To fix this,mingw setting was modified by adding stdc++-98.

With 5.9.7, ./configure is not showing anything. 

We have enabled qt and qt-dev from petalinux-config -c rootfs and even disabled cpio images from creation as we were exceeding image size and cpio image compilation was failing.

How can we install qt and customize it for zynq and use for GUI development?

0 Kudos
1 Reply
haydenport
Visitor
Visitor
362 Views
Registered: ‎03-15-2019

^ Seconded. Did you ever figure this out? I also am having a similar issue that should be resolved by AR59172. Unfortunately that fix did nothing for me. Only difference is that im using a ZCU104.
0 Kudos