UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Contributor
Contributor
1,990 Views
Registered: ‎05-05-2015

petalinux 2018.1 refusing to install

Jump to solution

Hello,

 

I am trying to install petalinux v2018.1 in Ubuntu 16.04LTS. The installer keeps complaining about missing openssl development libraries:

INFO: Checking installation environment requirements...
INFO: Checking free disk space
INFO: Checking installed tools
INFO: Checking installed development libraries
ERROR: You are missing these development libraries required by PetaLinux:

- openssl

 

However I have installed them according to the instructions:

sudo apt-get install libssl-dev 

and they are showing up:

 

sudo dpkg -s libssl-dev

 

Package: libssl-dev
Status: install ok installed
Priority: optional
Section: libdevel
Installed-Size: 7028
Maintainer: Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Architecture: amd64
Multi-Arch: same
Source: openssl
Version: 1.0.2g-1ubuntu4.12

 

 Is this not the right version ? Any suggestions  please ?

 

Thanks,

0 Kudos
1 Solution

Accepted Solutions
Highlighted
Contributor
Contributor
2,499 Views
Registered: ‎05-05-2015

Re: petalinux 2018.1 refusing to install

Jump to solution

So it seems that there was something wrong with my user account. Maybe a profile or privilige setting.

 

I created another user account called test and manage to run the petalinux installer from there. It found the openssl development libraries while my normal user account could not do it.

0 Kudos
8 Replies
Moderator
Moderator
1,975 Views
Registered: ‎12-04-2016

Re: petalinux 2018.1 refusing to install

Jump to solution

Hi

 

Try installing these 2 packages and see if the error goes away?

sudo apt-get install libssl-dev

sudo apt-get install lib32z1

 

 

Best Regards

Shabbir

0 Kudos
Contributor
Contributor
1,962 Views
Registered: ‎05-05-2015

Re: petalinux 2018.1 refusing to install

Jump to solution

Unfortunately I am still getting:

 

ERROR: You are missing these development libraries required by PetaLinux:

- openssl

 

after:

 

sudo apt-get install libssl-dev (that I had done before)

sudo apt-get install lib32z1

 

and I have been verifying that all the packages are installed according to the PDF of requirements.

0 Kudos
Moderator
Moderator
1,953 Views
Registered: ‎09-12-2007

Re: petalinux 2018.1 refusing to install

Jump to solution

Are all the dependancies installed as per the petalinux user guide:

https://www.xilinx.com/support/documentation/sw_manuals/xilinx2018_1/ug1144-petalinux-tools-reference-guide.pdf

 

example:

apt-get update

spt-get install lib-ssl-dev

0 Kudos
Contributor
Contributor
1,946 Views
Registered: ‎05-05-2015

Re: petalinux 2018.1 refusing to install

Jump to solution

I have verified that everything else is installed according to:

 

https://www.xilinx.com/support/documentation/sw_manuals/xilinx2018_1/ug1144-petalinux-tools-reference-guide.pdf

 

keeps complaining about development libraries required by PetaLinux: - openssl

 

I have checked for libss-dev as follows,

 

apt list libssl-dev -a Listing... Done
Listing... Done
libssl-dev/xenial-updates,xenial-security,now 1.0.2g-1ubuntu4.12 amd64 [installed]
libssl-dev/xenial 1.0.2g-1ubuntu4 amd64

 

Does this looks  OK ?

0 Kudos
Moderator
Moderator
1,939 Views
Registered: ‎12-04-2016

Re: petalinux 2018.1 refusing to install

Jump to solution

Hi

 

It seems to me, some issue with your ubuntu distribution. You may try running these and check once

sudo apt-get purge openssl
sudo apt-get install openssl libssl-dev

 

 

Best Regards

Shabbir

 

0 Kudos
Highlighted
Contributor
Contributor
2,500 Views
Registered: ‎05-05-2015

Re: petalinux 2018.1 refusing to install

Jump to solution

So it seems that there was something wrong with my user account. Maybe a profile or privilige setting.

 

I created another user account called test and manage to run the petalinux installer from there. It found the openssl development libraries while my normal user account could not do it.

0 Kudos
Visitor nish1709
Visitor
1,827 Views
Registered: ‎04-15-2018

Re: petalinux 2018.1 refusing to install

Jump to solution

While installing petalinux 2018.1 following error is coming and I am not able to solve the problem with solutions discussed in these solutions. Kindly reply ASAP. Below is the error shown in the log file.

 


INFO: Checking installer checksum...
INFO: Extracting PetaLinux installer...
INFO: Checking installation environment requirements...
INFO: Installing PetaLinux...
*********************************************
WARNING: You haven't specified the installation location.
*********************************************
*********************************************
WARNING: By default, it will be installed in your working directory: /home/vconnect2/petalinux 2018.1
*********************************************
*********************************************
ERROR: PetaLinux installation directory is invalid: '/home/vconnect2/petalinux 2018.1' includes space.
*********************************************
Please refer to the PetaLinux Tools Installation Guide.

Check the troubleshooting guide at the end of that manual, and if you are
unable to resolve the issue please contact customer support with file:
/home/vconnect2/petalinux 2018.1/petalinux_installation_log

 

0 Kudos
Observer mrm
Observer
1,824 Views
Registered: ‎05-09-2018

Re: petalinux 2018.1 refusing to install

Jump to solution

Hi nish1709

 

This is because the directory name "petalinux 2018.1"  in "/home/vconnect2/petalinux

2018.1/petalinux_installation_log" is improper. Remove the space and use a proper directory name.

 

Regards

mrm

0 Kudos