cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted
Visitor
Visitor
741 Views
Registered: ‎10-15-2018

petalinux 2018.2 boot failure

Hi, I have the exact same problem like this guys here :

https://forums.xilinx.com/t5/Embedded-Linux/Petalinux-boot-with-JTAG/td-p/713472/highlight/true?device-view=desktop

I use windows 10 with ubuntu 16.04 vmware machine.

I did everything in the pdf - ug1144 to install petalinux in the vm machine and boot it on the Zedboard evaluation kit (Zynq7000).

I did the command : "petalinux-boot --jtag --prebuilt 3"

and it sends me this log :

 

WARNING: Will not program bitstream on the target. If you want to program bitstream,
WARNING: please run petalinux-package --prebuilt to put the bitstream to the prebuitl directory,
WARNING: or use --fpga --bitstream option to specify a bitstream.
INFO: Append dtb - /home/dorubuntu/petalinux_projects/zynq7000_petalinux/pre-built/linux/images/system.dtb and other options to boot zImage
INFO: Launching XSDB for file download and boot.
INFO: This may take a few minutes, depending on the size of your image.
rlwrap: warning: your $TERM is 'xterm-256color' but rlwrap couldn't find it in the terminfo database. Expect some problems.: Inappropriate ioctl for device
no targets found with "name =~ "arm*#0"". available targets: none
while executing
"error "no targets found with \"$params(filter)\". available targets:$target_list""
(procedure "targets" line 177)
invoked from within
"targets -set -nocase -filter {name =~ "arm*#0"}"
(file "/tmp/tmp.BYPFZlDvkn" line 3)
INFO: The XSDB log is as follows
attempting to launch hw_server

****** Xilinx hw_server v2018.2
**** Build date : Jun 14 2018-20:18:37
** Copyright 1986-2018 Xilinx, Inc. All Rights Reserved.

INFO: hw_server application started
INFO: Use Ctrl-C to exit hw_server application

INFO: To connect to this hw_server instance use url: TCP:127.0.0.1:3121

 

some other comments about the problem :

I use vivado 2018.2 hardware server to connect the jtag to the vm machine.

It works perfectly fine in SDK and Vivado.

I did read anything on the post I added and in the end the guy with the problem said he solved it by "Build the jtag dev rules".

I don't know what it means and when I looked it up I could find anything useful to build those rules.

He said that it worked for him only if the jtag could be scanned as non-root user, which again I don't know how to do it.

 

Thank you everyone who reads this!

0 Kudos
1 Reply
Highlighted
90 Views
Registered: ‎07-05-2019

Hello,

 

I have a similar problem with Petalinux 2018.2. When I program the Zynq 7000 SoC with FPGA bitstream using Windows SDK 2018.2 or Vivado, it works. I am able to test the connecion to hw_server in SDK.

 

However it doesnt work when I try to program from the linux VM using SDK 2018.2. 

 

I get the following error too:

rlwrap: warning: your $TERM is 'xterm-256color' but rlwrap couldn't find it in the terminfo database. Expect some problems.: Inappropriate ioctl for device
no targets found with "name =~ "ARM*#0"". available targets: none
while executing
"error "no targets found with \"$params(filter)\". available targets:$target_list""
(procedure "targets" line 177)
invoked from within
"targets -set -filter {name =~ "ARM*#0"}"

 

I would greatly appreciate your help.

Thank you ver much in advance!

 

0 Kudos