UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Contributor
Contributor
281 Views
Registered: ‎10-29-2018

petalinux 2018.2 installation failure

Dear Sir,

I am trying to install petalinux2018.2 on ubuntu 16.04.

I have downloaded the installer.  Then I am following UG976guide to install it in /opt/pkg/petalinux/

Following commands I have run : 

sudo dpkg-reconfigure dash

sudo chown -R g-testbed2/opt/pkg/petalinux

cd /opt/pkg/petalinux

chmod +x petalinux-v2018.2-final-installer.run

./petalinux-v2018.2-final-installer.run


// ERROR: You are missing the following system tools required by PetaLinux:

- xvfb-run //

sudo apt-get install xvfb

./petalinux-v2018.2-final-installer.run

// ERROR: the SDK requires the following missing utilities, please install them: g++
*********************************************
ERROR: Failed to install Yocto SDK for aarch64.//

sudo apt-get install g++-5

./petalinux-v2018.2-final-installer.run

 

Even though latest g++ is installed in my system, I am getting missing error for g++ and Ypctp SDK for aarch 64 is not getting installed.

Please help me out.

Thank you,

Regards,

Puja Kumari

0 Kudos
1 Reply
Moderator
Moderator
212 Views
Registered: ‎12-04-2016

Re: petalinux 2018.2 installation failure

Hi Puja

 

Please follow UG1144 for petalinux installation

https://www.xilinx.com/support/documentation/sw_manuals/xilinx2018_3/ug1144-petalinux-tools-reference-guide.pdf

 

Best Regards

Shabbir

0 Kudos