cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
raghuram1a
Adventurer
Adventurer
19,567 Views
Registered: ‎12-18-2018

petalinux-2018.3 installation on ubuntu 16.04.03

Jump to solution

Hi,

 

I am trying to install petalinux installer petalinux-v2018.3-final-installer.run on ubuntu 16.04.03 Desktop with RAM 8GB as normal user from /home/<username>/ folder with out root even i am facing below

errors

Error :

 

INFO: Checking installation environment requirements...
awk: read error (Bad address)

Please refer to the PetaLinux Tools Installation Guide.

Check the troubleshooting guide at the end of that manual, and if you are
unable to resolve the issue please contact customer support with file:
   /home/administrator/PETA-LINUX/petalinux_installation_log

awk: read error (Bad address)
./petalinux-v2018.3-final-installer.run: line 139: /tmp/tmp.sYPDxJkzOq/: Is a directory
ERROR: Failed to extract Petalinux installer...

Could anyone help me how to resolve this issue to continue further.

Thanks,

Raghuram

0 Kudos
46 Replies
witch
Newbie
Newbie
1,329 Views
Registered: ‎01-14-2019

Great! Thank you very much!

0 Kudos
raghuram1a
Adventurer
Adventurer
1,309 Views
Registered: ‎12-18-2018

Hi Puja,

 

Please follow the Document UG1144 for petalinux installation gude . This i svery good document.

 

regards,

Raghuram

0 Kudos
elilau
Visitor
Visitor
1,236 Views
Registered: ‎02-17-2019

Hi 

In order to fast ramp up with Ubuntu of my ZCU-102 Rev 1.1 EVB.

Is there Link for downloading img of pre-built  of petalinux-v2018.3- run ubuntu or CentOS that tested and working ?

Thanks

Eli

0 Kudos
ngokulk
Visitor
Visitor
1,089 Views
Registered: ‎05-14-2019
In short run the below command for Ubuntu 16.04.3 (as per Table 2-1: Packages and Linux Workstation Environments):
apt install dos2unix iproute2 gawk git make net-tools libncurses5-dev tftpd zlib1g:i386 libssl-dev flex bison libselinux1 gnupg wget diffstat chrpath socat xterm autoconf libtool tar unzip texinfo zlib1g-dev gcc-multilib build-essential libsdl1.2-dev libglib2.0-dev screen pax gzip
0 Kudos
jineshjhonsa
Observer
Observer
1,069 Views
Registered: ‎10-21-2018

How did you solved it?

0 Kudos
ngokulk
Visitor
Visitor
1,061 Views
Registered: ‎05-14-2019

Installing all the dependencies in Table 2-1: Packages and Linux Workstation Environments under the column (Ubuntu 16.04.3) solves the issues during installation.

For e.g. if any dependency is not pre-installed (or even not right version e.g gawk), the installer doesn't throw error directly, instead the installer fails with an indirect message like "bad address"

So better make sure the the listed dependencies are met before running the installer.

0 Kudos
anjuman_degirum
Visitor
Visitor
952 Views
Registered: ‎06-18-2019

How was the original issue with the installation error resolved? @raghuram1a 

0 Kudos
ahmedmohamed85
Contributor
Contributor
922 Views
Registered: ‎07-02-2015

can u please tell me how did u solve the awk: read error (Bad address) because i am stuck in the same problem and i cannot find a solution

0 Kudos
ngokulk
Visitor
Visitor
899 Views
Registered: ‎05-14-2019

Install the below dependencies as listed in PetaLinux Tools Documentation Reference Guide

Chapter 2:

for e.g. Ubuntu:


sudo apt-get install -y gcc gawk git make net-tools libncurses5-dev tftpd zlib1g-dev libssl-dev
flex bison libselinux1 gnupg wget diffstat chrpath socat xterm autoconf libtool tar unzip
texinfo zlib1g-dev gcc-multilib build-essential libsdl1.2-dev libglib2.0-dev zlib1g:i386

Also ensure you have reconfigured sh to bash

ls -l /bin/sh -> dash : Wrong

ls -l /bin/sh -> bash : Correct

If you system is not configured for bash, run

sudo dpkg-reconfigure dash 

and select <No> in the window

 

This solves the awk bad address error and installation issues.

0 Kudos
860 Views
Registered: ‎06-04-2019

i got the same error, how you reolve it please help me.

0 Kudos
darshan007
Observer
Observer
804 Views
Registered: ‎08-09-2019
Have you pressed enter for "Press Enter to display the license agreements"?
0 Kudos
dmainkar
Visitor
Visitor
749 Views
Registered: ‎08-27-2019
Hi, How did you solve this error?
I have tried updating all the prerequisites. Still i get the error.
0 Kudos
viggsy
Observer
Observer
719 Views
Registered: ‎05-16-2019

Hi,

 I am getting the same error now. 

 

Could you please tell me what must be done to resolve it?

Thanks

0 Kudos
zhaolili
Visitor
Visitor
640 Views
Registered: ‎10-26-2018
原因:在ubuntu中已经取消掉了gmake,都用make代替。解决: sudo apt-get install gawk
0 Kudos
allen_wang
Newbie
Newbie
534 Views
Registered: ‎10-20-2019
hi,
I encountered the same problem as you, how did you solve it in the end
0 Kudos
aeonjose
Participant
Participant
470 Views
Registered: ‎12-09-2019

Run the comman

sudo apt install gawk 

Then try to run the installer.

This solved my problem.

0 Kudos
miaoxin
Observer
Observer
451 Views
Registered: ‎07-07-2018
yes, you can input "sudo apt-get install gawk".this can do.
0 Kudos