UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Explorer
Explorer
1,700 Views
Registered: ‎09-27-2013

petalinux: Enabling fpga_manager

Jump to solution

I'm trying to follow some other forum threads (https://forums.xilinx.com/t5/Embedded-Linux/ZynqMP-PL-Programming-Throught-Linux-petalinux-2016-3/td-p/754914) on using the petalinux command line to reprogram the PL. It looks like a command would be similar to this:

 

"echo bitstream.bin > /sys/class/fpga_manager/fpga0/firmware"

 

However, I don't have "/fpga0/firmware" available in that directory. I do have "/sys/class/fpga_manager/" but it's an empty directory. I'm using petalinux 2017.4.

 

I'm assuming I need to enable that somewhere in "petalinux-config -c ..." but I am having trouble finding it.

 

Any help?

0 Kudos
1 Solution

Accepted Solutions
Voyager
Voyager
2,078 Views
Registered: ‎09-14-2016

Re: petalinux: Enabling fpga_manager

Jump to solution

Hi @rdb9879,

 

For info i'm using a zynq7000 too and i don't have /sys/class/fpga_manager/fpga0/firmware

 

You shouldn't try to flash your bitstream with echo cmd.

 

Please try cat bitstream.bit > /dev/xdevcfg 

 

Cheers,

Trigger

0 Kudos
8 Replies
Moderator
Moderator
1,673 Views
Registered: ‎06-27-2017

Re: petalinux: Enabling fpga_manager

Jump to solution
Hi,
You can check below configuration.
Device Drivers ---> FPGA Configuration Support ---> <*> Xilinx Zynqmp FPGA
Also refer below wiki
http://www.wiki.xilinx.com/Solution+ZynqMP+PL+Programming
Best Regards
Kranthi
--------------------------
Don't forget to reply, kudo, and accept as solution.
0 Kudos
Explorer
Explorer
1,669 Views
Registered: ‎09-27-2013

Re: petalinux: Enabling fpga_manager

Jump to solution

I don't have the Xilinx Zynqmp FPGA option...

 

FPGA_Config_Options.png

 

To get to this menu, I went "petalinux-config -c kernel"

0 Kudos
Explorer
Explorer
1,587 Views
Registered: ‎09-27-2013

Re: petalinux: Enabling fpga_manager

Jump to solution

Any more ideas on this?

0 Kudos
Voyager
Voyager
1,548 Views
Registered: ‎09-14-2016

Re: petalinux: Enabling fpga_manager

Jump to solution

Hi @rdb9879,

 

Which board do you use ? Custom ?

 

It's strange because this part of kernel is called by defconfig -> https://github.com/Xilinx/linux-xlnx/blob/master/arch/arm/configs/xilinx_zynq_defconfig#L217

 

Cheers,

Trigger

0 Kudos
Explorer
Explorer
1,543 Views
Registered: ‎09-27-2013

Re: petalinux: Enabling fpga_manager

Jump to solution

I'm using the Avnet Microzed. But when I created the petalinux project, I did not import a BSP, I just created a new project and imported the *.hdf file.

0 Kudos
Moderator
Moderator
1,529 Views
Registered: ‎09-12-2007

Re: petalinux: Enabling fpga_manager

Jump to solution

Microzed is zynq7000, not zynqmp

0 Kudos
Explorer
Explorer
1,511 Views
Registered: ‎09-27-2013

Re: petalinux: Enabling fpga_manager

Jump to solution

Okay, then I guess I will circle back around to my original problem:

 

This command doesn't work:

"echo bitstream.bin > /sys/class/fpga_manager/fpga0/firmware"

 

because the sub directories "fpga0/firmware" do not exist. What do I do to make these directories exist? Ultimately, I am trying to reprogram the FPGA fabric with a new *.bit file using the command line.

 

Thanks.

0 Kudos
Voyager
Voyager
2,079 Views
Registered: ‎09-14-2016

Re: petalinux: Enabling fpga_manager

Jump to solution

Hi @rdb9879,

 

For info i'm using a zynq7000 too and i don't have /sys/class/fpga_manager/fpga0/firmware

 

You shouldn't try to flash your bitstream with echo cmd.

 

Please try cat bitstream.bit > /dev/xdevcfg 

 

Cheers,

Trigger

0 Kudos