cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
abhishekkunal
Contributor
Contributor
288 Views
Registered: ‎02-10-2019

petalinux boot hang issue

Hi,

I have developed a Vivado project and tested it with baremetal appliation on ZynqMPSOC it works fine.

But whenever i biuld the petalinux image using the same xsa file and try to boot it hangs at...

irq-xilinx: /amba_pl@/interrupt-control@a0030000: num_irq=2, edge=0x3

I have attached the boot log and the pdf of block design.

Please check and let me know what am i missing ?

 

 

 

0 Kudos
4 Replies
stephenm
Moderator
Moderator
222 Views
Registered: ‎09-12-2007

Does it hang at the same location all the time?

Have you programmed the PL?

0 Kudos
abhishekkunal
Contributor
Contributor
182 Views
Registered: ‎02-10-2019

Yes It hangs there all the time.. I amusing this command to boot linux via JTAG

petalinux-boot --jtag --u-boot --fpga --bitstream ./images/linux/system.bit --image ./images/linux/image.ub

0 Kudos
stephenm
Moderator
Moderator
166 Views
Registered: ‎09-12-2007

Looks fine, can you add the --tcl dump.tcl to this command, and share the resulting file?

Can you stop in uboot, and to a md a0030000, does this work?

0 Kudos
abhishekkunal
Contributor
Contributor
132 Views
Registered: ‎02-10-2019

Hi @stephenm ,

I tried  md a0030000 but that doesn't work.

Please find the attached tcl dump you asked for.

I replaced AXIGPIOs with EMIOs and linux is booting fine, but i want to use only AXIGPIOs not EMIOs.

I don't know what's wrong with AXIGPIOs in my project.

 

0 Kudos