UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Visitor mrzhang_
Visitor
1,033 Views
Registered: ‎11-26-2017

petalinux-boot --qemu --prebuilt 3 failed

When I run command 

petalinux-boot --qemu --prebuilt 3

 

Tools :

PC : Ubuntu 2016.04

Petalinux 2017.2

 

Error:

 

petalinux-boot --qemu --prebuilt 3


INFO: Set QEMU tftp to /home/ceshiyiqi/zcu102/xilinx-zcu102-2017.2/images/linux
用法: grep [选项]... PATTERN [FILE]...
试用'grep --help' 来获得更多信息。
INFO: TCP PORT is free
INFO: Starting aarch64 QEMU
INFO:  qemu-system-aarch64 -M arm-generic-fdt -global xlnx,zynqmp-boot.cpu-num=0 -global xlnx,zynqmp-boot.use-pmufw=true   -display none -device loader,file=/home/ceshiyiqi/zcu102/xilinx-zcu102-2017.2/pre-built/linux/images/pmu_rom_qemu_sha3.elf,cpu-num=0 -gdb tcp::9000 -dtb /tmp/tmp.vAFrFPmxVo     -hw-dtb /home/ceshiyiqi/zcu102/xilinx-zcu102-2017.2/images/linux/zynqmp-qemu-multiarch-arm.dtb -machine-path /tmp/tmp.0ey3keugwi -pflash /home/ceshiyiqi/zcu102/xilinx-zcu102-2017.2/images/linux/nand0.qcow2 -pflash /home/ceshiyiqi/zcu102/xilinx-zcu102-2017.2/images/linux/nand0.qcow2 -m 4G
qemu-system-aarch64: Unable to get size of device tree file '/tmp/tmp.vAFrFPmxVo'
qemu-system-aarch64: Error: Unable to load Device Tree /tmp/tmp.vAFrFPmxVo
INFO: Set QEMU tftp to /home/ceshiyiqi/zcu102/xilinx-zcu102-2017.2/images/linux
用法: grep [选项]... PATTERN [FILE]...
试用'grep --help' 来获得更多信息。
INFO: TCP PORT is free
INFO: Starting aarch64 QEMU
INFO:  qemu-system-aarch64 -M arm-generic-fdt -global xlnx,zynqmp-boot.cpu-num=0 -global xlnx,zynqmp-boot.use-pmufw=true   -display none -device loader,file=/home/ceshiyiqi/zcu102/xilinx-zcu102-2017.2/pre-built/linux/images/pmufw.elf,cpu-num=0 -gdb tcp::9000 -dtb /tmp/tmp.Vx8DsA3UUZ     -hw-dtb /home/ceshiyiqi/zcu102/xilinx-zcu102-2017.2/images/linux/zynqmp-qemu-multiarch-arm.dtb -machine-path /tmp/tmp.0ey3keugwi -pflash /home/ceshiyiqi/zcu102/xilinx-zcu102-2017.2/images/linux/nand0.qcow2 -pflash /home/ceshiyiqi/zcu102/xilinx-zcu102-2017.2/images/linux/nand0.qcow2 -m 4G
qemu-system-aarch64: Unable to get size of device tree file '/tmp/tmp.Vx8DsA3UUZ'
qemu-system-aarch64: Error: Unable to load Device Tree /tmp/tmp.Vx8DsA3UUZ
INFO: Set QEMU tftp to /home/ceshiyiqi/zcu102/xilinx-zcu102-2017.2/images/linux
用法: grep [选项]... PATTERN [FILE]...
试用'grep --help' 来获得更多信息。
INFO: TCP PORT is free
INFO: Starting aarch64 QEMU
INFO:  qemu-system-aarch64 -M arm-generic-fdt -global xlnx,zynqmp-boot.cpu-num=0 -global xlnx,zynqmp-boot.use-pmufw=true   -display none -device loader,file=/home/ceshiyiqi/zcu102/xilinx-zcu102-2017.2/pre-built/linux/images/bl31.elf,cpu-num=0 -device loader,file=/home/ceshiyiqi/zcu102/xilinx-zcu102-2017.2/pre-built/linux/images/Image,addr=0x00080000 -device loader,file=/home/ceshiyiqi/zcu102/xilinx-zcu102-2017.2/pre-built/linux/images/system.dtb,addr=0x1407f000 -device loader,file=/home/ceshiyiqi/zcu102/xilinx-zcu102-2017.2/build/misc/linux-boot/linux-boot.elf -gdb tcp::9000 -dtb /tmp/tmp.8w6EUmsvxa     -hw-dtb /home/ceshiyiqi/zcu102/xilinx-zcu102-2017.2/images/linux/zynqmp-qemu-multiarch-arm.dtb -machine-path /tmp/tmp.0ey3keugwi -pflash /home/ceshiyiqi/zcu102/xilinx-zcu102-2017.2/images/linux/nand0.qcow2 -pflash /home/ceshiyiqi/zcu102/xilinx-zcu102-2017.2/images/linux/nand0.qcow2 -m 4G
qemu-system-aarch64: Unable to get size of device tree file '/tmp/tmp.8w6EUmsvxa'
qemu-system-aarch64: Error: Unable to load Device Tree /tmp/tmp.8w6EUmsvxa

0 Kudos
1 Reply
Moderator
Moderator
923 Views
Registered: ‎09-12-2007

Re: petalinux-boot --qemu --prebuilt 3 failed

INFO:  qemu-system-aarch64 -M arm-generic-fdt -global xlnx,zynqmp-boot.cpu-num=0 -global xlnx,zynqmp-boot.use-pmufw=true   -display none -device loader,file=/home/ceshiyiqi/zcu102/xilinx-zcu102-2017.2/pre-built/linux/images/bl31.elf,cpu-num=0 -device loader,file=/home/ceshiyiqi/zcu102/xilinx-zcu102-2017.2/pre-built/linux/images/Image,addr=0x00080000 -device loader,file=/home/ceshiyiqi/zcu102/xilinx-zcu102-2017.2/pre-built/linux/images/system.dtb,addr=0x1407f000 -device loader,file=/home/ceshiyiqi/zcu102/xilinx-zcu102-2017.2/build/misc/linux-boot/linux-boot.elf -gdb tcp::9000 -dtb /tmp/tmp.8w6EUmsvxa     -hw-dtb /home/ceshiyiqi/zcu102/xilinx-zcu102-2017.2/images/linux/zynqmp-qemu-multiarch-arm.dtb -machine-path /tmp/tmp.0ey3keugwi -pflash /home/ceshiyiqi/zcu102/xilinx-zcu102-2017.2/images/linux/nand0.qcow2 -pflash /home/ceshiyiqi/zcu102/xilinx-zcu102-

 

Seems to be a parsing issue here. Can you try call the command manually, and remove the highlighted option

0 Kudos