UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Observer emilie
Observer
201 Views
Registered: ‎03-19-2019

petalinux-build errors

Hello everyone, 

I'm currently trying to use Petalinux 2018.1 but I'm facing issues. I installed Petalinux correctly but when I use "petalinux-build", here the errors : 

emilie@emilie-VirtualBox:~/Documents/GestionProject$ petalinux-build
[INFO] building project
[INFO] sourcing bitbake
INFO: bitbake petalinux-user-image
WARNING: You have included the meta-virtualization layer, but 'virtualization' has not been enabled in your DISTRO_FEATURES. Some bbappend files may not take effect. See the meta-virtualization README for details on enabling virtualization support.
ERROR: OE-core's config sanity checker detected a potential misconfiguration.
Either fix the cause of this error or at your own risk disable the checker (see sanity.conf).
Following is the list of potential problems / advisories:

MACHINE=ultra96-zynqmp is invalid. Please set a valid MACHINE in your local.conf, environment or other configuration file.


Summary: There was 1 WARNING message shown.
Summary: There was 1 ERROR message shown, returning a non-zero exit code.
ERROR: Failed to build project

I'm using the BSP for the Ultra96 which is "xilinx-ultra96-reva-v2018.2-final.bsp" thus, for Petalinux 2018.2. Maybe that's why I'm facing issue. The problem is that I can't find the BSP for the UItra96 for Petalinux 2018.1.

Regards,

Emilie 

 

0 Kudos
5 Replies
Adventurer
Adventurer
176 Views
Registered: ‎09-25-2018

Re: petalinux-build errors

hi @emilie , I am not an expert but did you check here ?

Observer emilie
Observer
142 Views
Registered: ‎03-19-2019

Re: petalinux-build errors

Hello @1ymw1 ,

Thank you for your reply!

Indeed, I checked this thread and all my settings are correctly set up... 

Regards,

Emilie

0 Kudos
Moderator
Moderator
131 Views
Registered: ‎12-04-2016

Re: petalinux-build errors

Hi @emilie 

Recommendation is to use petalinux 2018.2 installer to build ultra96 bsp, as we have added ultra96-zynqmp.conf file to meta-xilinx in 2018.2

 

 

0 Kudos
Observer emilie
Observer
125 Views
Registered: ‎03-19-2019

Re: petalinux-build errors

Hi @shabbirk ,

Thank you for your reply,

Is it ok to use Petalinux2018.2 with Vivado and SDK 2018.1 or do I have to upgrade the whole Xilinx Suite ?

Regards, 

Emilie

0 Kudos
Moderator
Moderator
121 Views
Registered: ‎12-04-2016

Re: petalinux-build errors

Hi @emilie 

Though not recommended to use two diiferent versions, as an experiment, you can give a try using vivado 2018.1 generated HDF with petalinux 2018.2

and see if that build successfully.

 

Best Regards

Shabbir

0 Kudos