cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
1,955 Views
Registered: ‎11-22-2017

petalinux-config -c kernel doesn't wait for menuconfig to terminate

Jump to solution

I'm having a problem running petalinux-config -c kernel. Basically, the menuconfig opens successfully in a separate MATE terminal window, but the underlying bitbake process doesn't wait for the menuconfig to complete before going on to perform the do_diffconfig task that updates my kernel recipe in meta-user. This means that any changes I make to the kernel configuration in the menu are lost.

 

Another data point - I tried running petalinux-config -c kernel from one of the virtual consoles (navigated there with Ctrl+Alt+F1) and it completed successfully. So, a) I *know* my PetaLinux installation can/does work as expected, and b) I have a workaraound, but I'd *really* like for this to work within my GUI environment!

 

I saved & diffed the config logs from the MATE terminal and virtual console sessions, and the only difference was these two lines, indicating that do_diffconfig has found the config changes I made to the kernel.

 

linux-xlnx-4.9-xilinx-v2017.3+gitAUTOINC+f1b1e077d6-r0 do_diffconfig: Config fragment has been dumped into:
 /home/stu/Desktop/test/build/tmp/work/plnx_arm-xilinx-linux-gnueabi/linux-xlnx/4.9-xilinx-v2017.3+gitAUTOINC+f1b1e077d6-r0/fragment.cfg

 

So - any suggestions/thoughts about what I could do to fix this?

 

Configuration:

PetaLinux 2017.3

Ubuntu 16.04 with MATE desktop (running as a VM under VirtualBox 5.1.30 on Windows 10)

0 Kudos
1 Solution

Accepted Solutions
2,492 Views
Registered: ‎11-22-2017

I think I have a fix... Seems that MATE terminal does something that bitbake doesn't like. Using a different terminal type (either by setting the default terminal to Gnome or xterm or adding a variable setting OE_TERMINAL="xterm" or OE_TERMINAL="screen" in the file <project-root>/build/conf/local.conf) seems to fix this issue.

View solution in original post

1 Reply
2,493 Views
Registered: ‎11-22-2017

I think I have a fix... Seems that MATE terminal does something that bitbake doesn't like. Using a different terminal type (either by setting the default terminal to Gnome or xterm or adding a variable setting OE_TERMINAL="xterm" or OE_TERMINAL="screen" in the file <project-root>/build/conf/local.conf) seems to fix this issue.

View solution in original post