UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Adventurer
Adventurer
121 Views
Registered: ‎06-18-2016

petalinux-create can't find librdi_commonxillic.so

Hi Xilinx,

I'm using Petalinux 2019.1, Ubuntu 18.04, x86_64. When I run petalinux-create (Usage and output shown below) I get the 'not found' error. I'm not having any other petalinux problems. First I checked that the file exists:

(LD_LIBRARY_PATH  = /opt/pkg/petalinux/2019.1/tools/xsct/lib/lnx64.o)

tgs@grinder:~/petalinux/xilinx-zc706-2019.1$ ls -l /opt/pkg/petalinux/2019.1/tools/xsct/lib/lnx64.o/librdi_commonxillic.so
-rwxr-xr-x 1 tgs tgs 3118192 May 11 13:09 /opt/pkg/petalinux/2019.1/tools/xsct/lib/lnx64.o/librdi_commonxillic.so

file $LD_LIBRARY_PATH/librdi_commonxillic.so
/opt/pkg/petalinux/2019.1/tools/xsct/lib/lnx64.o/librdi_commonxillic.so: ELF 64-bit LSB shared object, x86-64, version 1 (GNU/Linux), dynamically linked, stripped

When I run the create command I get this:

tgs@grinder:~/petalinux/xilinx-zc706-2019.1$ petalinux-create -t apps --template autoconf --name CLServer --enable --force
INFO: Create apps: CLServer
WARNING: Component "/home/tgs/petalinux/xilinx-zc706-2019.1/project-spec/meta-user/recipes-apps/CLServer" already exists.
WARNING: --force parameter specified, overwriting
INFO: New apps successfully created in /home/tgs/petalinux/xilinx-zc706-2019.1/project-spec/meta-user/recipes-apps/CLServer
INFO: Enabling created component...
INFO: sourcing bitbake
INFO: oldconfig rootfs
INFO: CLServer has been enabled
Failed to open PetaLinux lib: librdi_commonxillic.so: cannot open shared object file: No such file or directory.

When I do an ltrace on the above command this is the tail of the output:

getuid() = 1000
unsetenv("PETALINUX_ARCH_MICROBLAZE") = <void>
unsetenv("PETALINUX_ARCH_ZYNQ") = <void>
unsetenv("PETALINUX_ARCH_AARCH64") = <void>
setenv("PETALINUX_ARCH_MICROBLAZE", "y", 1) = 0
setenv("PETALINUX_ARCH_ZYNQ", "y", 1) = 0
setenv("PETALINUX_ARCH_AARCH64", "y", 1) = 0
dlopen("librdi_commonxillic.so", 10Couldn't find .rel*.plt section in "/opt/pkg/petalinux/2019.1/tools/xsct/lib/lnx64.o/libisl_iostreams.so"

The project appears to have already been created when the error occurs but I'm making no assumptions that it was successful. How can we fix this?

Cheers, Tom

 

0 Kudos