UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Observer kmbm
Observer
7,687 Views
Registered: ‎01-11-2016

petalinux eth0 problem

Hi,

I've built petalinux on my zynq, but I have problem with eth0. ifconfig works but connection not. If i want check mii info I have got mii not found. Where can be a problem.

 

my system-top.dts file:

{
aliases{
ethernet0=&gem0;
};
};

&gem0 {
    phy-handle = <&phy0>;
    ps7_ethernet_0_mdio: mdio {
        #address-cells = <1>;
        #size-cells = <0>;
        phy0: phy@0 {
            compatible = "marvell,88e1510";
            device_type = "ethernet-phy";
            reg = <0>;
        } ;
    } ;
};

 

0 Kudos
4 Replies
Scholar rfs613
Scholar
7,656 Views
Registered: ‎05-28-2013

Re: petalinux eth0 problem

Your device tree specifies a PHY address of 0... is that what your hardware actually has?

If the PHY address correct, then check the configuration of the MDIO pins in Vivado. If they incorrect, you will need to fix it, then generate a new FSBL.

Sometimes, PHY chips are held in reset via a GPIO pin. If that is the case on your board, this needs to be configured as well, before the PHY will be detected.

0 Kudos
Observer kmbm
Observer
7,620 Views
Registered: ‎01-11-2016

Re: petalinux eth0 problem

the address and pins are correct. It's problem with all peripherals ethernet uart spi ... Linux works but i can't communicate with any phy Only gpio works

0 Kudos
Participant jonbacon
Participant
7,516 Views
Registered: ‎08-06-2015

Re: petalinux eth0 problem

Do you have any ethernet connection at all? If you connect to a router/switch do the lights come on?

 

I found with the marvell 88e1510 that the phy has a delay on outgoing traffic, no idea why it defaults to on but you can turn it off. I've not found the "proper" way to turn it off but adding the following line to your dts file will turn off the delay and then issue a soft reset to the phy (needed for the change to actually happen)

 

marvell,reg-init = <2 21 0xffef 0x00 0 0 0x7fff 0x8000>;

Hope that helps

 

 

Jon

0 Kudos
Xilinx Employee
Xilinx Employee
7,500 Views
Registered: ‎07-01-2010

Re: petalinux eth0 problem

@kmbm

 

Do you observe the same behaviour at U-boot stage?

 

Regards,

Achutha

---------------------------------------------------------------------------------------------
Kindly note- Please mark the Answer as "Accept as solution" if information provided is helpful.

Give Kudos to a post which you think is helpful and reply oriented.
----------------------------------------------------------------------------------------
0 Kudos