cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
dshamgar
Observer
Observer
300 Views
Registered: ‎10-06-2020

petalinux glibc compatibility error (GLIBC_2.29)

Jump to solution

Hi, 

 

i have installed petalinux (2020.01) with all dependencies, and downloaded the BSP for the zcu102 zynqMP:

xilinx-zcu102-v2020.1-final.bsp

i built a petalinux project from the bsp, and i am trying to run qemu with the prebuilt images:

petalinux-boot --qemu --prebuilt 3

i get the following error (all over): see file qemu_error.txt attached

for "petalinux-build" i get the following error: see file build_error.txt attached

my platform is centos7.6 and i am running the petalinux through devtoolset-7 bash.

how can i resolve this please ? 

are the errors related to the bsp pre-compilation environment ? 

 

thanks,

doron

0 Kudos
1 Solution

Accepted Solutions
dshamgar
Observer
Observer
261 Views
Registered: ‎10-06-2020

after a l-o-n-g debug session i found that i had a collision in the LD_LIBRARY_PATH.

i deleted it (L_LIBRARY_PATH="") and the problem solved.

hope this helps someone in the future.

i will keep investigating about the specific collision and what path is causing the problem.

thanks

View solution in original post

0 Kudos
1 Reply
dshamgar
Observer
Observer
262 Views
Registered: ‎10-06-2020

after a l-o-n-g debug session i found that i had a collision in the LD_LIBRARY_PATH.

i deleted it (L_LIBRARY_PATH="") and the problem solved.

hope this helps someone in the future.

i will keep investigating about the specific collision and what path is causing the problem.

thanks

View solution in original post

0 Kudos