UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Visitor stonedown
Visitor
505 Views
Registered: ‎10-16-2018

petalinux-image-full has become the default image

Jump to solution

I am attempting to transition from petalinux-v2018.2 to petalinux-v2018.3, and I find that petalinux-image-full is the default image. Any idea why that might be the case?

0 Kudos
1 Solution

Accepted Solutions
Visitor stonedown
Visitor
476 Views
Registered: ‎10-16-2018

Re: petalinux-image-full has become the default image

Jump to solution

Looks like it wasn't the default image so much as it was just looking for that bbappend file. This seemed to help:

 

$ touch /path/to/project-spec/meta-user/recipes-core/images/petalinux-image-full.bbappend

0 Kudos
4 Replies
Visitor stonedown
Visitor
482 Views
Registered: ‎10-16-2018

Re: petalinux-image-full has become the default image

Jump to solution

For instance, the following now occurs with petalinux-v2018.3 for my existing project:

$ petalinux-config -c rootfs
[INFO] sourcing bitbake
[INFO] generating plnxtool conf
[INFO] generating meta-plnx-generated layer
[INFO] generating machine configuration
[INFO] configuring: rootfs
[INFO] generating kconfig for Rootfs
Traceback (most recent call last):
  File "rootfs_config.py", line 315, in <module>
    parse_args(sys.argv[1:])
  File "rootfs_config.py", line 290, in parse_args
    extract_packages_dot(packages_user)
  File "rootfs_config.py", line 257, in extract_packages_dot
    with open(packages_dot,'r') as fp:
IOError: [Errno 2] No such file or directory: '/path/to/project-spec/meta-user/recipes-core/images/petalinux-image-full.bbappend'
ERROR: Failed to generate rootfs /path/to/build/misc/rootfs_config/Kconfig.user
ERROR: Failed to config rootfs.

0 Kudos
Visitor stonedown
Visitor
477 Views
Registered: ‎10-16-2018

Re: petalinux-image-full has become the default image

Jump to solution

Looks like it wasn't the default image so much as it was just looking for that bbappend file. This seemed to help:

 

$ touch /path/to/project-spec/meta-user/recipes-core/images/petalinux-image-full.bbappend

0 Kudos
Observer rwillis
Observer
310 Views
Registered: ‎08-23-2018

Re: petalinux-image-full has become the default image

Jump to solution

Did you manage to compile 2018.3 after touching the missing file?

I have the same issue (and created the same file) but build fails later on. First a warning is given:

"WARNING: No recipes available for: </path/to>/project-spec/meta-user/recipes-core/images/petalinux-image.bbappend"

then the build fails:

"ERROR: fsbl-2018.3+gitAUTOINC+56f3da2afb-r0 do_compile: Function failed: do_compile (log file is located at </path/to>/build/tmp/work/zcu102_zynqmp-xilinx-linux/fsbl/2018.3+gitAUTOINC+56f3da2afb-r0/temp/log.do_compile.29694)"

 - Richard

 

0 Kudos
270 Views
Registered: ‎02-13-2019

Re: petalinux-image-full has become the default image

Jump to solution

Instead of doing a touch on the missing file I simply moved my old bbappend file to the new name.  I then re-enabled the recipes using petalinux-config -c rootfs.  This allowed my build to complete successfully.

mv </path/to>/project-spec/meta-user/recipes-core/images/petalinux-image.bbappend </path/to>/project-spec/meta-user/recipes-core/images/petalinux-image-full.bbappend

0 Kudos