UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Visitor jerry.liu
Visitor
8,101 Views
Registered: ‎06-20-2016

”random: nonblocking pool is initialized” take too much time

Env: petalinux-v2016.1-final & Xilinx-ZC706-v2-16.1-final.bsp

 

When I boot the linux on the ZC706, the last message " random: nonblocking pool is initialized " may take several minutes. That's too slow.

 

How can I figure out the reason why that's too slow? And How can I speed up that?

 

BTW: Because my own app wouldn't work until that message show up, I want to fix this issue ASAP.

 

0 Kudos
6 Replies
Xilinx Employee
Xilinx Employee
8,077 Views
Registered: ‎08-01-2008

Re: ”random: nonblocking pool is initialized” take too much time

chech this document

http://www.xilinx.com/support/documentation/sw_manuals/petalinux2015_4/ug1156-petalinux-tools-workflow-tutorial.pdf
Thanks and Regards
Balkrishan
--------------------------------------------------------------------------------------------
Please mark the post as an answer "Accept as solution" in case it helped resolve your query.
Give kudos in case a post in case it guided to the solution.
0 Kudos
Visitor jerry.liu
Visitor
8,064 Views
Registered: ‎06-20-2016

Re: ”random: nonblocking pool is initialized” take too much time

In the ug1156-petalinux-tools-workflow-tutorial.pdf, the Figure 2 shows the result I want as the following

random.png

 

But I couldn't find any description about what/how to do to speed up the nonblocking pool intializaiton.

Can you give me more clear clue such as which chapter or page?

0 Kudos
Adventurer
Adventurer
6,608 Views
Registered: ‎11-30-2015

Re: ”random: nonblocking pool is initialized” take too much time

Hi Jerry

It seems that I have the same problem in my application based on Avnet MMP Zynq board with Petalinux 2015.4.

Did you solved the problem about speed up the pool initialisation or did you find new information?

 

Regards

 

 

 

0 Kudos
Anonymous
Not applicable
6,551 Views

Re: ”random: nonblocking pool is initialized” take too much time

Are you trying to use getrandom(2)? This blocks until the non-blocking pool is initialized (it needs 128 bits of entropy). If you read /dev/urandom directly it won't block. It depends on what you need the randomness for - crypto keys? If you have a board with not much in the way of peripherals to generate hardware events then entropy will build slowly (like mine). If you have the ability you can save and re-use entropy across reboots (you can google for the procedure). It isn't practical in my case. Basically I just won't bother trying to create cryptographically strong keys on my target. If I wait on /dev/random it may as well be forever.

 

 

0 Kudos
Contributor
Contributor
1,849 Views
Registered: ‎05-18-2016

Re: ”random: nonblocking pool is initialized” take too much time

Does anyone solved this problem? I currently have the same issue - tcf-agent blocks until "random: nonblocking pool is initialized" message appears, which takes about 2 minutes.

0 Kudos
Adventurer
Adventurer
106 Views
Registered: ‎05-03-2012

Re: ”random: nonblocking pool is initialized” take too much time

Hi,

if you're using Qt, rebuild your qt library with the configure option

-no-feature-getentropy

Regards,

Helmut

0 Kudos