UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Observer zhongxp
Observer
9,157 Views
Registered: ‎01-30-2008

u-boot compile error!

1.gcc version 4.7.2 (Sourcery CodeBench Lite 2012.09-104) 2. Linux ubuntu 3.13.0-32-generic #57~precise1-Ubuntu SMP Tue Jul 15 03:50:54 UTC 2014 i686 i686 i386 GNU/Linux root@ubuntu:~/build/u-boot-xlnx# make zynq_zed_config # # configuration written to .config # root@ubuntu:~/build/u-boot-xlnx# make scripts/kconfig/conf --silentoldconfig Kconfig CHK include/config.h UPD include/config.h GEN include/autoconf.mk GEN include/autoconf.mk.dep GEN spl/include/autoconf.mk CHK include/config/uboot.release CHK include/generated/version_autogenerated.h CHK include/generated/timestamp_autogenerated.h UPD include/generated/timestamp_autogenerated.h CC lib/asm-offsets.s CHK include/generated/generic-asm-offsets.h CC arch/arm/lib/asm-offsets.s CHK include/generated/asm-offsets.h HOSTCC tools/envcrc.o HOSTCC tools/common/env_embedded.o HOSTLD tools/envcrc HOSTCC tools/mkenvimage.o HOSTLD tools/mkenvimage HOSTCC tools/aisimage.o In file included from tools/aisimage.c:10:0: include/image.h:907:27: fatal error: openssl/evp.h: No such file or directory compilation terminated. make[1]: *** [tools/aisimage.o] Error 1 make: *** [tools] Error 2 root@ubuntu:~/build/u-boot-xlnx#
0 Kudos
3 Replies
Xilinx Employee
Xilinx Employee
9,153 Views
Registered: ‎07-01-2010

Re: u-boot compile error!

@zhongxp

 

check this link which has the details of the issue and fix.

 

-Achutha

---------------------------------------------------------------------------------------------
Kindly note- Please mark the Answer as "Accept as solution" if information provided is helpful.

Give Kudos to a post which you think is helpful and reply oriented.
----------------------------------------------------------------------------------------
0 Kudos
Observer zhongxp
Observer
9,116 Views
Registered: ‎01-30-2008

Re: u-boot compile error!

a new error as the following


DTC arch/arm/dts/zynq-zc702.dtb
dtc: invalid option -- 'i'
Usage:
dtc [options] <input file>
0 Kudos
Adventurer
Adventurer
9,090 Views
Registered: ‎05-29-2015

Re: u-boot compile error!

Are you manually calling DTC or using a script? If manual:

To create a dtb:
dtc -O dtb -I dts -o devicetree.dtb inputfile.dts

To extract a dtb to a dts:
dtc -O dts -I dtb -o out.dts devicetree.dtb
0 Kudos