UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
7,256 Views
Registered: ‎03-30-2017

udc-core: couldn't find an available UDC - added [g1] to list of pending drivers

I'm working with UVC. Following these instructions. Got the an error when I ran the gadget (this tell me to run the gadget and this tells me how to do it)

 

Here is how I activate the gadget

echo fe200000.dwc3 > UDC

Once I execute this line, I get the following error:

udc-core: couldn't find an available UDC - added [g1] to list of pending drivers

Has anyone run into the problem before? How did you fix it?

0 Kudos
3 Replies
Adventurer
Adventurer
7,111 Views
Registered: ‎12-02-2014

Re: udc-core: couldn't find an available UDC - added [g1] to list of pending drivers

I'm having the same issue starting g_serial on a custom board.

 

udc-core: couldn't find an available UDC - added [g_serial] to list of pending drivers

 

Can someone provide the required Kernel config options for UDC on zynqmp (dwc3)?

0 Kudos
6,962 Views
Registered: ‎08-30-2016

Re: udc-core: couldn't find an available UDC - added [g1] to list of pending drivers

0 Kudos
Newbie jdonald313
Newbie
6,737 Views
Registered: ‎10-16-2017

Re: udc-core: couldn't find an available UDC - added [g1] to list of pending drivers

Hey Xilinx users,

I don't have the same board as you to test, but when I hit the same error message on my Pi Zero (both with ConfigFS and g_serial) I came across this forum post.

For the Pi, it turned out to be I had my device tree overlay misconfigured such that OTG wasn't enabled, and it fixed once I set `dtoverlay=dwc2`. Here's dwc2 for the Pi Zero for reference: https://github.com/raspberrypi/linux/blob/rpi-4.9.y/arch/arm/boot/dts/overlays/dwc2-overlay.dts

I would recommend you check the corresponding Zynq device tree and device tree overlay in your kernel configuration. Confirm that it has `dr_mode = "otg";` and is configured appropriately.

Tags (1)
0 Kudos