cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Adventurer
Adventurer
8,617 Views
Registered: ‎09-28-2016

watchdog timed out. Internal reset not enabled?

Jump to solution

Hi, all

board:zc706

linux:petalinux2016.02

 

I have experienced a problem recently. when I open the watchdog "/dev/watchdog", but don't write it. wait for a while,the console print the log "watchdog timed out. Internal reset not enabled", but my board don't reset.

 

who can help me, and give me some hints.thanks in advance.

 

 

Tom

 

0 Kudos
1 Solution

Accepted Solutions
Highlighted
Moderator
Moderator
12,293 Views
Registered: ‎10-06-2016

Re: watchdog timed out. Internal reset not enabled?

Jump to solution

Hi @atower

 

The example provided in the wiki page is for the MPSoC so when using SoC there are some changes in the device-tree that you may consider. As you pointed in your previous post the watchdog controller default description is the following one:

 

watchdog0: watchdog@f8005000 {
     clocks = <&clkc 45>;
     compatible = "cdns,wdt-r1p2";
     interrupt-parent = <&intc>;
     interrupts = <0 9 1>;
     reg = <0xf8005000 0x1000>;
     timeout-sec = <10>;
};

As you can see the clocks property is defined in the default template so there is no requirement to add it in the top file. However as the wiki page indicates the reset-on-timeout property have to be added in your description.

 

So if you want to have the reset feature this is the required dts entry:

&watchdog0 {
    status = "okay";
    reset-on-timeout;
};

Once you boot the Linux image you can check if your new properties has been loaded properly in the boot process and then run the "echo s > /dev/watchdog0" command to run the watchdog reset.

 

Capture.PNG


Ibai
Don’t forget to reply, kudo, and accept as solution.

View solution in original post

0 Kudos
9 Replies
Highlighted
Xilinx Employee
Xilinx Employee
8,610 Views
Registered: ‎08-01-2008

Re: watchdog timed out. Internal reset not enabled?

Jump to solution
check this link
http://www.wiki.xilinx.com/Cadence+WDT+Driver
Thanks and Regards
Balkrishan
--------------------------------------------------------------------------------------------
Please mark the post as an answer "Accept as solution" in case it helped resolve your query.
Give kudos in case a post in case it guided to the solution.
0 Kudos
Highlighted
Adventurer
Adventurer
8,580 Views
Registered: ‎09-28-2016

Re: watchdog timed out. Internal reset not enabled?

Jump to solution

Hi,Balkrishan

 

Thanks for your reply, I have another question to consult you. what's the differences between "/dev/watchdog" and "/dev/watchdog0"? which watchdog is the "candence wdt" corresponded?

 

 

Tom

0 Kudos
Highlighted
Adventurer
Adventurer
8,576 Views
Registered: ‎09-28-2016

Re: watchdog timed out. Internal reset not enabled?

Jump to solution

Hi, Balkrishan

after I add 

&watchdog0 {
    status = "okay";
    clocks = <&clk100>;
};

 in ${PETALINUX_PORJECT}/subsystems/linux/configs/devie-tree/system-top.dts , run petalinux-build , there is a error, print "Reference is non-existent node or label "clk100",

my board is zc706, what should I add "clocks = " instead of  clk100?

 

my ${PETALINUX_PORJECT}/subsystems/linux/configs/devie-tree/zynq-7000.dtsi watchdog show below

 

watchdog0: watchdog@f8005000 {
     clocks = <&clkc 45>;
     compatible = "cdns,wdt-r1p2";
     interrupt-parent = <&intc>;
     interrupts = <0 9 1>;
     reg = <0xf8005000 0x1000>;
     timeout-sec = <10>;

};

 

Tom

0 Kudos
Highlighted
Adventurer
Adventurer
8,569 Views
Registered: ‎09-28-2016

Re: watchdog timed out. Internal reset not enabled?

Jump to solution

if I add 

&watchdog0 {
    status = "okay";
    clocks = <&clkc 45>;
};

 run "petalinux-build" successfully, and run "echo s > /dev/watchdog0", but it still print "Watchdog timed out. Internal reset not enabled"

 

Why? did I miss some procedures?

 

Tom

0 Kudos
Highlighted
Moderator
Moderator
12,294 Views
Registered: ‎10-06-2016

Re: watchdog timed out. Internal reset not enabled?

Jump to solution

Hi @atower

 

The example provided in the wiki page is for the MPSoC so when using SoC there are some changes in the device-tree that you may consider. As you pointed in your previous post the watchdog controller default description is the following one:

 

watchdog0: watchdog@f8005000 {
     clocks = <&clkc 45>;
     compatible = "cdns,wdt-r1p2";
     interrupt-parent = <&intc>;
     interrupts = <0 9 1>;
     reg = <0xf8005000 0x1000>;
     timeout-sec = <10>;
};

As you can see the clocks property is defined in the default template so there is no requirement to add it in the top file. However as the wiki page indicates the reset-on-timeout property have to be added in your description.

 

So if you want to have the reset feature this is the required dts entry:

&watchdog0 {
    status = "okay";
    reset-on-timeout;
};

Once you boot the Linux image you can check if your new properties has been loaded properly in the boot process and then run the "echo s > /dev/watchdog0" command to run the watchdog reset.

 

Capture.PNG


Ibai
Don’t forget to reply, kudo, and accept as solution.

View solution in original post

0 Kudos
Highlighted
Adventurer
Adventurer
8,534 Views
Registered: ‎09-28-2016

Re: watchdog timed out. Internal reset not enabled?

Jump to solution

Hi,ibaie

 

Thanks for your reply, follow your solution, the "/dev/watchdog0" can work successfully. If I want to modify the timeout time, e.g, defautl timeout time is 10s, if I want to modify to 5s, what should I do. I'm try to simply modify "timeout-sec = <10>;" to "timeout-sec = <5>;" but it failed, it's still 10s timeout.

 

Thanks again.

Tom

 

0 Kudos
Highlighted
Visitor
Visitor
7,036 Views
Registered: ‎08-28-2016

Re: watchdog timed out. Internal has enabled,but the system do not reboot

Jump to solution

i  use the watchdog with this link http://www.wiki.xilinx.com/Cadence+WDT+Driver,the devicetree i set the reset-on-timeout

i write the cmd : echo s > /dev/watchdog0 ,but after 10 seconds ,the system  is  halted and not reboot.

 

I want the system reboot when watchdog time out,but the system is halted now.the linux kernel release is 2015.3,i dont konw what i should do ?

0 Kudos
Highlighted
Observer
Observer
1,479 Views
Registered: ‎08-10-2016

Re: watchdog timed out. Internal has enabled,but the system do not reboot

Jump to solution

were u able to resolve this?

0 Kudos
Highlighted
Xilinx Employee
Xilinx Employee
1,431 Views
Registered: ‎02-15-2018

Re: watchdog timed out. Internal has enabled,but the system do not reboot

Jump to solution

Hi ,

 

What is  your boot mode that you are using?

0 Kudos