UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Observer soteria0
Observer
6,811 Views
Registered: ‎05-22-2014

xapp1171 and Petalinux

Hello,

 

I am having trouble getting Petalinux  to run with xapp1171. I am using Petalinux Tools 2014.2 and Vivado 2014.2. I loaded the design on Vivado, created a bitstream, and tried to create a Petalinux image to boot from. The Petalinux kernel that is used for the image is 3.14, based off of the xilinx-v2014.2.01 tag in the Xilinx Github repository. I can boot the kernel image using qemu, but when I try to get it on the board via jtag or booting from the SD card, the boot hangs. The following is the terminal output when it hangs:

 

 

Memory: ECC disabled
DRAM:  1 GiB
MMC:   zynq_sdhci: 0
SF: Detected S25FL128S_64K with page size 512 Bytes, erase size 128 KiB, total 32 MiB
*** Warning - bad CRC, using default environment

In:    serial
Out:   serial
Err:   serial
Net:   Gem.e000b000
U-BOOT for soteria_haims

..   Verifying Hash Integrity ... crc3201653d40
     Data Size:    17229 Bytes = 16.8 KiB
     Architecture: ARM
     Hash algo:    crc32
     Hash value:   3a94100c
   Verifying Hash Integrity ... crc32+ OK
   Booting using the fdt blob at 0x1653d40
   Uncompressing Kernel Image ...  0xc0599160   (5701 kB)
      .init : 0xc059a000 - 0xc0927a00   (3639 kB)
      .data : 0xc0928000 - 0xc096bb40   ( 271 kB)
       .bss : 0xc096bb4c - 0xc0e9e81c   (5324 kB)
sched_clock: 64 bits at 333MHz, resolution 3ns, wraps every 3298534883328ns
... MAX_LOCKDEP_SUBCLASSES:  8
... MAX_LOCK_DEPTH:          48
... MAX_LOCKDEP_KEYS:        8191
... CLASSHASH_SIZE:          4096
... MAX_LOCKDEP_ENTRIES:     16384
... MAX_LOCKDEP_CHAINS:      32768
... CHAINHASH_SIZE:          16384
 memorMount-cache hash table entries: 2048 (order: 1, 8192 bytes)
Mountpoint-cache hash table entries: 2048 (order: 1, 8192 bytes)
L310 cache controller enabled
l2x0: 8 ways, CACHE_ID 0x410000c8, AUX_CTRL 0x72760000, Cache size: 512 kB
CPU1: Booted secondary processor
CPU1: thread -1, cpu 1, socket 0, mpidr 80000001
Brought up 2 CPUs
SMP: Total of 2 processors activated.
CPU: All CPU(s) started in SVC mode.
devtmpfs: initialized
NET: Registered protocol family 16
DMA: preallocated 256 KiB pool for atomic coherent allocations
cpuidle: using governor ladder
cpuidle: using governor menu
bio: create slab <bio-0> at 0

 

If I create the boot image using the pre-built bitstream (download.bit) it gets to the command just fine as well, so it seems to be connected to the bitstream or the hardware configuration.
 

If anyone has any suggestions, they would be greatly appreciated.

 

Regards,

John

0 Kudos
3 Replies
Observer soteria0
Observer
6,746 Views
Registered: ‎05-22-2014

Re: xapp1171 and Petalinux

Hello,

 

I've tried building the bitstream using Vivado 2013.3, but the boot still hangs on the same line. I tried changing from SLAB to SLOB in the config, and I've also tried disabling in the config file VGA_ARB and SCSI since they usually print right after the "bio:..." line. Still prints the same line and hangs.

 

Any suggestions would be greatly appreciated.

 

Regards,

John

0 Kudos
Observer soteria0
Observer
6,699 Views
Registered: ‎05-22-2014

Re: xapp1171 and Petalinux

Would creating a BSP in the SDK from the hardware project help? I was using a BSP provided by Xilinx. At the momeny, I am using the 2014.2 BSP for the ZC706 provided by Xilinx. I can be found at :
http://www.xilinx.com/support/download/index.html/content/xilinx/en/downloadNav/petalinux.html

Whenever I try to create a BSP for the, I get the following error:
11:42:43 ERROR : [Hsm 55-1545] Problem running tcl command ::sw_petalinux_v2_00_a::petalinux_drc : no such variable
(read trace on "env(PETALINUX)")
invoked from within
"append path " $env(PETALINUX)/components/edk_user_repository""
(procedure "get_path" line 34)
invoked from within
"get_path"
(procedure "::sw_petalinux_v2_00_a::petalinux_drc" line 10)
invoked from within
"::sw_petalinux_v2_00_a::petalinux_drc petalinux"
[Hsm 55-1440] Error(s) while running DRCs.
11:42:43 ERROR : Error generating bsp sources: Failed to generate BSP.
11:42:43 ERROR : Failed to generate sources for BSP project petalinux_bsp_0
org.eclipse.core.runtime.CoreException: Internal error occurred while generating bsp sources. Please check the SDK Log view for further details.
at com.xilinx.sdk.sw.ui.handlers.RegenBspSourcesHandler.internalGenerateBsp(RegenBspSourcesHandler.java:178)
at com.xilinx.sdk.sw.ui.handlers.RegenBspSourcesHandler.access$2(RegenBspSourcesHandler.java:163)
at com.xilinx.sdk.sw.ui.handlers.RegenBspSourcesHandler$1$1.run(RegenBspSourcesHandler.java:131)
at org.eclipse.core.internal.resources.Workspace.run(Workspace.java:2344)
at com.xilinx.sdk.sw.ui.handlers.RegenBspSourcesHandler$1.run(RegenBspSourcesHandler.java:135)
at org.eclipse.jface.operation.ModalContext$ModalContextThread.run(ModalContext.java:121)
0 Kudos
Xilinx Employee
Xilinx Employee
6,688 Views
Registered: ‎09-10-2008

Re: xapp1171 and Petalinux

Hi John,

I would go back to your 1st method and stick with it to debug it. It looks like you're trying to build PCIe endpoint into your bitstream.

In these cases I typically would start commenting out nodes in the device tree that are optional til I get it to boot. I tend to start by taking out all optional, get it to boot, then start putting them back in. In this case I'd take out any nodes for devices in the PL for sure.

There are some other threads similar to this that you might search on the forum about hangs during boot.

Hope that helps,
John
0 Kudos