UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Visitor medmakni
Visitor
266 Views
Registered: ‎07-26-2019

xen BOOT fail after build with petalinux 2018.2 on the ULTRA96 board

Hi,

I built a Xen image with petalinux 2018.2 and xilinx-ultra96-reva-v2018.2-final.bsp following this steps:

https://xilinx-wiki.atlassian.net/wiki/spaces/A/pages/18841783/Building+Xen+Hypervisor+with+Petalinux+2018.1

After I copied the required files to my SD card partitions(BOOT.bin,xen.ub,system.dtb,image,rootfs.cpio.gz.u-boot to BOOT partition and extracted the rootfs.cpio in the rootfs partition). I got NO RESPONSE AT ALL from the board. I'm stuck here for over a month, so please help me ! and thank you

0 Kudos
2 Replies
Moderator
Moderator
221 Views
Registered: ‎05-10-2017

Re: xen BOOT fail after build with petalinux 2018.2 on the ULTRA96 board

What do you mean by no response from the board? Do you atleast see fsbl run? Can you post your boot log here?

-------------------------------------------------------------------------
Don’t forget to reply, kudo, and accept as solution.
-------------------------------------------------------------------------
Visitor medmakni
Visitor
193 Views
Registered: ‎07-26-2019

Re: xen BOOT fail after build with petalinux 2018.2 on the ULTRA96 board

Hi,thank you for your response.

I connected the board via UART and display ports but i see nothing in the terminal even fsbl. I didn't find the boot.log file anywhere as the boot doesn't start at all.

PS: If I copy the Image.ub and BOOT.bin into the boot partition of the SD card, It boots but It's not xen with Linux as Dom0, It's just Linux as I see nothing related to xen when I run dmesg and the /sys/hypervisor/uuid file is missing. I even tried the sd card and initramfs in the Root file system type in the petalinux configuration and then copied the files but It's the same result.

Screenshot from 2019-07-30 10-50-12.png
0 Kudos