UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Explorer
Explorer
1,767 Views
Registered: ‎04-19-2016

zc702 xapp794 mount: mounting /dev/mmcblk0p1 on /mnt failed: No such file or directory

Jump to solution

Hello,

 

I have put the serial terminal log below. No further experience about the linux. Any advise please? 

I looked at mnt folder is seen by typing -ls command. However mnt folder is empty. Is this normal?

The correct terminal log should be same as shown Xapp794, page 14-16. 

 

 

U-Boot 2011.03 (Jul 12 2012 - 09:03:13)

DRAM: 256 MiB
MMC: SDHCI: 0
Using default environment

In: serial
Out: serial
Err: serial
Net: zynq_gem
Hit any key to stop autoboot: 0
Copying Linux from SD to RAM...
Device: SDHCI
Manufacturer ID: 3
OEM: 5344
Name: SD08G
Tran Speed: 25000000
Rd Block Len: 512
SD version 1.10
High Capacity: Yes
Capacity: 7948206080
Bus Width: 1-bit
reading zImage

2399280 bytes read
reading devicetree.dtb

3972 bytes read
reading ramdisk8M.image.gz

2498905 bytes read
## Starting application at 0x00008000 ...
Uncompressing Linux... done, booting the kernel.
Booting Linux on physical CPU 0
Linux version 3.3.0-14.2-build1-01464-ged63a4d (elzinga@xcoapps53) (gcc version 4.6.1 (Sourcery CodeBench Lite 2011.09-50) ) #2 SMP PREEMPT Mon Jul 23 16:41:03 MDT 2012
CPU: ARMv7 Processor [413fc090] revision 0 (ARMv7), cr=18c5387d
CPU: PIPT / VIPT nonaliasing data cache, VIPT aliasing instruction cache
Machine: Xilinx Zynq Platform, model: Xilinx Zynq ZC702
bootconsole [earlycon0] enabled
Memory policy: ECC disabled, Data cache writealloc
PERCPU: Embedded 7 pages/cpu @c190b000 s5696 r8192 d14784 u32768
Built 1 zonelists in Zone order, mobility grouping on. Total pages: 255744
Kernel command line: console=ttyPS0,115200 root=/dev/ram rw initrd=0x800000,8M i p=:::::eth0:dhcp earlyprintk
PID hash table entries: 4096 (order: 2, 16384 bytes)
Dentry cache hash table entries: 131072 (order: 7, 524288 bytes)
Inode-cache hash table entries: 65536 (order: 6, 262144 bytes)
Memory: 240MB 768MB = 1008MB total
Memory: 1009296k/1009296k available, 39280k reserved, 270336K highmem
Virtual kernel memory layout:
vector : 0xffff0000 - 0xffff1000 ( 4 kB)
fixmap : 0xfff00000 - 0xfffe0000 ( 896 kB)
vmalloc : 0xf0000000 - 0xff000000 ( 240 MB)
lowmem : 0xc0000000 - 0xef800000 ( 760 MB)
pkmap : 0xbfe00000 - 0xc0000000 ( 2 MB)
modules : 0xbf000000 - 0xbfe00000 ( 14 MB)
.text : 0xc0008000 - 0xc0408c34 (4100 kB)
.init : 0xc0409000 - 0xc042c640 ( 142 kB)
.data : 0xc042e000 - 0xc045bba0 ( 183 kB)
.bss : 0xc045bbc4 - 0xc0475e10 ( 105 kB)
Preemptible hierarchical RCU implementation.
Verbose stalled-CPUs detection is disabled.
NR_IRQS:128
xlnx,ps7-ttc-1.00.a #0 at 0xf0000000, irq=43
Console: colour dummy device 80x30
Calibrating delay loop... 1332.01 BogoMIPS (lpj=6660096)
pid_max: default: 32768 minimum: 301
Mount-cache hash table entries: 512
CPU: Testing write buffer coherency: ok
CPU0: thread -1, cpu 0, socket 0, mpidr 80000000
smp_twd: clock not found: -2
Calibrating local timer... 333.56MHz.
hw perfevents: enabled with ARMv7 Cortex-A9 PMU driver, 7 counters available
Setting up static identity map for 0x2f1188 - 0x2f11bc
CPU1: Booted secondary processor
CPU1: thread -1, cpu 1, socket 0, mpidr 80000001
Brought up 2 CPUs
SMP: Total of 2 processors activated (2664.03 BogoMIPS).
devtmpfs: initialized
NET: Registered protocol family 16
L310 cache controller enabled
l2x0: 8 ways, CACHE_ID 0x410000c8, AUX_CTRL 0x72360000, Cache size: 524288 B
registering platform device 'pl330' id 0
registering platform device 'arm-pmu' id 0
hw-breakpoint: found 5 (+1 reserved) breakpoint and 1 watchpoint registers.
hw-breakpoint: maximum watchpoint size is 4 bytes.
MIO pin 47 not assigned(00001220)
xslcr xslcr.0: at 0xF8000000 mapped to 0xF0008000
bio: create slab <bio-0> at 0
gpiochip_add: registered GPIOs 0 to 245 on device: xgpiops
xgpiops e000a000.gpio: gpio at 0xe000a000 mapped to 0xf000a000
SCSI subsystem initialized
usbcore: registered new interface driver usbfs
usbcore: registered new interface driver hub
usbcore: registered new device driver usb
Switching to clocksource xttcpss_timer1
NET: Registered protocol family 2
IP route cache hash table entries: 32768 (order: 5, 131072 bytes)
TCP established hash table entries: 131072 (order: 8, 1048576 bytes)
TCP bind hash table entries: 65536 (order: 7, 786432 bytes)
TCP: Hash tables configured (established 131072 bind 65536)
TCP reno registered
UDP hash table entries: 512 (order: 2, 16384 bytes)
UDP-Lite hash table entries: 512 (order: 2, 16384 bytes)
NET: Registered protocol family 1
RPC: Registered named UNIX socket transport module.
RPC: Registered udp transport module.
RPC: Registered tcp transport module.
RPC: Registered tcp NFSv4.1 backchannel transport module.
Trying to unpack rootfs image as initramfs...
rootfs image is not initramfs (no cpio magic); looks like an initrd
Freeing initrd memory: 8192K
xscugtimer xscugtimer.0: ioremap fe00c200 to f000c200 with size 400
pl330 dev 0 probe success
highmem bounce pool size: 64 pages
JFFS2 version 2.2. (NAND) (SUMMARY) © 2001-2006 Red Hat, Inc.
msgmni has been set to 1459
io scheduler noop registered
io scheduler deadline registered
io scheduler cfq registered (default)
e007½¹Í½±•[ttyPS0] enabled, bootconsole disabled
console [ttyPS0] enabled, bootconsole disabled
xdevcfg f8007000.devcfg: ioremap f8007000 to f0060000 with size 100
brd: module loaded
loop: module loaded
m25p80 spi1.0: n25q128 (16384 Kbytes)
7 ofpart partitions found on MTD device spi1.0
Creating 7 MTD partitions on "spi1.0":
0x000000000000-0x000000080000 : "qspi-fsbl"
0x000000080000-0x000000100000 : "qspi-u-boot"
0x000000100000-0x000000600000 : "qspi-linux"
0x000000600000-0x000000620000 : "qspi-device-tree"
0x000000620000-0x000000700000 : "qspi-user"
0x000000700000-0x000000800000 : "qspi-scratch"
0x000000800000-0x000001000000 : "qspi-rootfs"
xqspips e000d000.spi: at 0xE000D000 mapped to 0xF0062000, irq=51
GEM: BASEADDRESS hw: e000b000 virt: f0064000
XEMACPS mii bus: probed
eth0, pdev->id -1, baseaddr 0xe000b000, irq 54
ehci_hcd: USB 2.0 'Enhanced' Host Controller (EHCI) Driver
xusbps-ehci xusbps-ehci.0: Xilinx PS USB EHCI Host Controller
xusbps-ehci xusbps-ehci.0: new USB bus registered, assigned bus number 1
xusbps-ehci xusbps-ehci.0: irq 53, io mem 0x00000000
xusbps-ehci xusbps-ehci.0: USB 2.0 started, EHCI 1.00
hub 1-0:1.0: USB hub found
hub 1-0:1.0: 1 port detected
Initializing USB Mass Storage driver...
usbcore: registered new interface driver usb-storage
USB Mass Storage support registered.
Xilinx PS USB Device Controller driver (Apr 01, 2011)
mousedev: PS/2 mouse device common for all mice
i2c /dev entries driver
xi2cps e0004000.i2c: 100 kHz mmio e0004000 irq 57
si570 1-005d: registered si570 with default frequency 156250000 Hz
si570 1-005d: set initial output frequency 148500000 Hz
i2c i2c-0: Added multiplexed i2c bus 1
i2c i2c-0: Added multiplexed i2c bus 2
at24 3-0054: 1024 byte 24c08 EEPROM, writable, 1 bytes/write
i2c i2c-0: Added multiplexed i2c bus 3
i2c i2c-0: Added multiplexed i2c bus 4
rtc-pcf8563 5-0051: chip found, driver version 0.4.3
rtc-pcf8563 5-0051: low voltage detected, date/time is not reliable.
rtc-pcf8563 5-0051: retrieved date/time is not valid.
rtc-pcf8563 5-0051: rtc core: registered rtc-pcf8563 as rtc0
i2c i2c-0: Added multiplexed i2c bus 5
i2c i2c-0: Added multiplexed i2c bus 6
i2c i2c-0: Added multiplexed i2c bus 7
i2c i2c-0: Added multiplexed i2c bus 8
pca954x 0-0074: registered 8 multiplexed busses for I2C switch pca9548
Linux video capture interface: v2.00
gspca_main: v2.14.0 registered
uvcvideo: Unable to create debugfs directory
usbcore: registered new interface driver uvcvideo
USB Video Class driver (1.1.1)
WDT OF probe
xwdtps f8005000.swdt: Xilinx Watchdog Timer at 0xf006a000 with timeout 10 second s
sdhci: Secure Digital Host Controller Interface driver
sdhci: Copyright(c) Pierre Ossman
sdhci-pltfm: SDHCI platform and OF driver helper
mmc0: SDHCI controller on e0100000.sdhci [e0100000.sdhci] using ADMA
usbcore: registered new interface driver usbhid
usbhid: USB HID core driver
TCP cubic registered
NET: Registered protocol family 17
VFP support v0.3: implementor 41 architecture 3 part 30 variant 9 rev 4
Registering SWP/SWPB emulation handler
rtc-pcf8563 5-0051: low voltage detected, date/time is not reliable.
rtc-pcf8563 5-0051: retrieved date/time is not valid.
rtc-pcf8563 5-0051: hctosys: invalid date/time
RAMDISK: gzip image found at block 0
mmc0: new SDHC card at address e624
mmcblk0: mmc0:e624 SD08G 7.40 GiB
mmcblk0:
VFS: Mounted root (ext2 filesystem) on device 1:0.
devtmpfs: mounted
Freeing init memory: 140K
Starting rcS...
++ Mounting filesystem
++ Setting up mdev
++ Mounting SD card to /mnt
mount: mounting /dev/mmcblk0p1 on /mnt failed: No such file or directory
++ Configuring IP Address
/etc/init.d/rcS: line 24: /mnt/config_my_ip.sh: not found
++ Starting telnet daemon
++ Starting http daemon
httpd: chdir(/mnt/www): No such file or directory
++ Starting ftp daemon
++ Starting dropbear (ssh) daemon
rcS Complete
/etc/init.d/rcS: line 41: /mnt/launch_my_app.sh: not found
zynq> ls
README     licenses          proc     update_qspi.sh
bin               linuxrc             root      usr
dev              lost+found       sbin     var
etc              mnt                  sys
lib               opt                   tmp
zynq> cd mnt
zynq> ls
zynq> ls
zynq>

Tags (4)
0 Kudos
1 Solution

Accepted Solutions
Highlighted
Xilinx Employee
Xilinx Employee
2,612 Views
Registered: ‎02-20-2014

Re: zc702 xapp794 mount: mounting /dev/mmcblk0p1 on /mnt failed: No such file or directory

Jump to solution

Looks like your SD card doesn't have the first partition. Can you confirm if /dev/mmcblk0p1 exists.

If not  Prepare the SD card. Use SD formatter tool to create a FAT partition, https://www.sdcard.org/downloads/formatter_4/ and copy the XAPP images again and retry the boot.

 

Hope it helps.

 

Thanks,

Radhey

2 Replies
Highlighted
Xilinx Employee
Xilinx Employee
2,613 Views
Registered: ‎02-20-2014

Re: zc702 xapp794 mount: mounting /dev/mmcblk0p1 on /mnt failed: No such file or directory

Jump to solution

Looks like your SD card doesn't have the first partition. Can you confirm if /dev/mmcblk0p1 exists.

If not  Prepare the SD card. Use SD formatter tool to create a FAT partition, https://www.sdcard.org/downloads/formatter_4/ and copy the XAPP images again and retry the boot.

 

Hope it helps.

 

Thanks,

Radhey

Explorer
Explorer
1,709 Views
Registered: ‎04-19-2016

Re: zc702 xapp794 mount: mounting /dev/mmcblk0p1 on /mnt failed: No such file or directory

Jump to solution

Hello @radheys

 

There is no /dev/mmcblk0p1 . I did not know that I should format the SD car via such an SD_CardFormatter before putting Xapp794 boot files inside it.  I downloaded the SD_CardFormatter and I formatted the SD card. App note is seen works properly. 

 

Thank you,

 

Tags (3)
0 Kudos