UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
1,673 Views
Registered: ‎09-30-2011

zc706 U-Boot dhcp doesn't work

Jump to solution

Hello!

 

I have a zc706 board. I built my image(s) using yocto (rocko branch) and was able to successfully boot the board to Linux without issue. Now I want to be able to do a network boot using DHCP from u-boot but am not able to get that to work. Immediately after the BOOTP broadcast message I get a "data abort" error displayed. It looks like u-boot has the network and DHCP configured but I keep getting the "data abort" error.

 

Any ideas about what is going wrong and how to fix it?

0 Kudos
1 Solution

Accepted Solutions
2,165 Views
Registered: ‎09-30-2011

Re: zc706 U-Boot dhcp doesn't work

Jump to solution

I rolled back to the pyro branch and u-boot is fully functional. So the rocko branch u-boot has an issue. I will stick to pyro since you indicated that rocko is not yet verified and validated

0 Kudos
8 Replies
Moderator
Moderator
1,641 Views
Registered: ‎12-04-2016

Re: zc706 U-Boot dhcp doesn't work

Jump to solution

Hi Neil

 

Are you able to ping from u-boot?

 

 

Best Regards

Shabbir

0 Kudos
1,630 Views
Registered: ‎09-30-2011

Re: zc706 U-Boot dhcp doesn't work

Jump to solution
Yes. ping appears to work.
0 Kudos
1,620 Views
Registered: ‎09-30-2011

Re: zc706 U-Boot dhcp doesn't work

Jump to solution

I just tried ping again. If I set a static ip address (which it appears to require) for the zc706 then I get the same 'crash' with the data abort message. Without the static IP it complains that ipaddr is not set

0 Kudos
Moderator
Moderator
1,605 Views
Registered: ‎12-04-2016

Re: zc706 U-Boot dhcp doesn't work

Jump to solution

Hi Neil

 

Did you configure the petalinux to select static IP? You can do something like this

petalinux-config ---> u-boot Configuration->TFTP Server IP address ---> Specify static IP address
or

alternatively, if you are nou using petalinux flow, then you can define this macro in u-boot configuration file 
For example, #define CONFIG_SERVERIP 192.168.42.3

 

 

Best Regards

Shabbir

0 Kudos
1,601 Views
Registered: ‎09-30-2011

Re: zc706 U-Boot dhcp doesn't work

Jump to solution
I am using yocto. I can try that server IP config. But seeing as these are all environment variables settable at run time, why would this fix it when setting these variables at run time has no beneficial effect?
0 Kudos
Moderator
Moderator
1,593 Views
Registered: ‎04-24-2017

Re: zc706 U-Boot dhcp doesn't work

Jump to solution

Hi neil@formidableengineeringconsultants.com,

 

Rocko release is based on 4.14 kernel which is not public which should be available in 3 weeks.

 

When you use Rocko with 4.9 kernel we haven't validated from Xilinx engineering team and that is not our supported flow. The results could be unpredictable.

Thanks,
Sandeep
PetaLinux Yocto | Embedded SW Support

---------------------------------------------------------------------------
Don’t forget to Reply, Kudo, and Accept as Solution.
---------------------------------------------------------------------------
0 Kudos
1,572 Views
Registered: ‎09-30-2011

Re: zc706 U-Boot dhcp doesn't work

Jump to solution

Thanks Sandeep. I think the issue is in u-boot and not the kernel. So there may be a problem in the rocko flavor of u-boot. I will try rolling back to an earlier branch. I don't have a compelling reason to use rocko except that it's new :-)

0 Kudos
2,166 Views
Registered: ‎09-30-2011

Re: zc706 U-Boot dhcp doesn't work

Jump to solution

I rolled back to the pyro branch and u-boot is fully functional. So the rocko branch u-boot has an issue. I will stick to pyro since you indicated that rocko is not yet verified and validated

0 Kudos