cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
sanghyun_kim
Observer
Observer
141 Views
Registered: ‎02-17-2020

zcu106 evaluation kit fan controller run a maximum speed.

if i created a project from petalinux bsp, there is Vivado project in hardware directory.

xilinx-zcu106-2020.1/hardware/xilinx-zcu106-2020.1/xilinx-zcu106-2020.1.xpr

 

and booting petalinux use this hardware (*.xsa, *.bit), fan is run a maximum speed for a while, and be silenced soon.

this is correct behavior described in zcu106 manual.

Note: At initial power on, it is normal for the fan controller to energize at full speed for a few seconds.

 

but i create new block design for zcu106 board without unused IP, fan run a full speed and it wouldn't be slowed.

sanghyun_kim_0-1617251657344.png

 

I configure everything the same as bsp(Clock, IO ...) and tried the function(ethernet, Display port , UART Console, USB ...) it is operate correctly.

but fan controller does not.

 

i can find code (may) related fan controller in petalinux workspace which configured from BSP hardware.

grep -r FANFAIL .
./components/yocto/workspace/sources/u-boot-xlnx/arch/arm/dts/zynqmp-zcu216-revA.dts: gpio-line-names = "MAX6643_OT_B", "MAX6643_FANFAIL_B", "MIO26_PMU_INPUT_LS", "", /* 0 - 3 */ ./components/yocto/workspace/sources/u-boot-xlnx/arch/arm/dts/zynqmp-zcu104-revA.dts: * 3 - MAX6643_FANFAIL_B ./components/yocto/workspace/sources/u-boot-xlnx/arch/arm/dts/zynqmp-zcu208-revA.dts: gpio-line-names = "MAX6643_OT_B", "MAX6643_FANFAIL_B", "MIO26_PMU_INPUT_LS", "DAC_AVTT_VOUT_SEL", /* 0 - 3 */ ./components/yocto/workspace/sources/u-boot-xlnx/arch/arm/dts/zynqmp-zcu111-revA.dts: * 1 - MAX6643_FANFAIL_B ./components/yocto/workspace/sources/u-boot-xlnx/arch/arm/dts/zynqmp-zcu104-revC.dts: * 3 - MAX6643_FANFAIL_B

but i can't find anything these kinds of file in petalinux workspace configured from my block design.

 

i think when i run a petalinux-configure --get-hw-description *.xsa, there is some information about fan controller.

how can enable fan controller on my block design?

 

0 Kudos
0 Replies