UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Newbie seshug22
Newbie
149 Views
Registered: ‎02-18-2019

DMA sends same multiple ethernet frames

Hi,

I am getting the multiples frames once I start the transmission by clearing the word [1] of the allocated buffer descriptors. Soon after the clearing the bit, I am getting same frames  multiple times in Wire Shark. Please feel free to ask any information required.

ETH_Frames.PNG
0 Kudos
1 Reply
Xilinx Employee
Xilinx Employee
101 Views
Registered: ‎01-09-2019

Re: DMA sends same multiple ethernet frames

Hello @seshug22 ,

Have you confirmed that your hardware works for your design?  Can you put an ILA in the system and probe the (I am assuming) AXI interfaces, and send us the waveform?

That would give a lot of information of whether this is a hardware or software problem (if you can tell us what you think it is that might guide advice as well).

Can you also show us what you are doing when you say you are getting multiple frames?  What kind of data are you sending?  And what does "clearing the word [1]" mean in terms of the allocated BDs?

Thanks,
Caleb
-------------------------------------------------------------------------
Don’t forget to reply, kudo, and accept as solution.
-------------------------------------------------------------------------
0 Kudos