UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Observer rtg
Observer
2,567 Views
Registered: ‎05-23-2017

Error in using Open Picoblaze Assembler

Jump to solution

I am using the Opbasm 1.3 but I am always getting the error "ERROR: Address exceeds memory bounds:400".  I have tried different programs.  It showed up even on the sample "auto_baud_rate_control.psm" which is provided with picoblaze.  It worked fine with the default assembler.  Please provide any assistance, if possible.

 

Thanks.

0 Kudos
1 Solution

Accepted Solutions
Observer rtg
Observer
4,692 Views
Registered: ‎05-23-2017

Re: Error in using Open Picoblaze Assembler

Jump to solution

Hi. I found the solution.  Using -r when compliling it through the terminal, it removes the dead code.  It worked fine after that.

0 Kudos
2 Replies
Observer rtg
Observer
4,693 Views
Registered: ‎05-23-2017

Re: Error in using Open Picoblaze Assembler

Jump to solution

Hi. I found the solution.  Using -r when compliling it through the terminal, it removes the dead code.  It worked fine after that.

0 Kudos
Explorer
Explorer
2,028 Views
Registered: ‎04-24-2014

Re: Error in using Open Picoblaze Assembler

Jump to solution

Yes, OPBASM optimizes code (dead code elimination) There are settings and pragmas to control dead code elimination and code preservation. See the detailed documentation on GitHub for more details.

0 Kudos