UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Visitor pa2ees42
Visitor
7,877 Views
Registered: ‎08-31-2015

Linux kernel disables ps to pl clocks

Jump to solution

I am using a Microzed 7010, Vivado 2015.2, SDK 2015.2, building the linux kernel, u-boot, and fsbl all from Xilinx's repository (using the 2015.2 tags in git).  

 

I have a verilog module that divides down an external clock to blink on an LED at 1Hz, and another verilog module that divides down FCLK_CLK0 (from the PS) to blink on an LED at 2Hz.  

 

I boot the microzed from an SD card with boot.bin, uImage, and devicetree.dtb on it.  It boots through the fsbl fine (LEDs are both flashing).  It then goes thorugh u-boot fine (LEDs are still both flashing).  When the linux kernel starts to boot, the LED driven by FCLK_CLK0 from the PS stops flashing.  

 

I think that the kernel is somehow disabling the PS to PL clocks, or level shifters, but I'm not sure how to debug, or where to look to solve the issue.

0 Kudos
1 Solution

Accepted Solutions
Explorer
Explorer
14,838 Views
Registered: ‎11-25-2014

Re: Linux kernel disables ps to pl clocks

Jump to solution

A lot of people have stumbled on this one, including us more than once. See if this helps:

 

http://forums.xilinx.com/t5/Embedded-Linux/Can-access-PL-register-from-u-boot-but-not-petalinux/m-p/647821#M13843

 

5 Replies
Explorer
Explorer
14,839 Views
Registered: ‎11-25-2014

Re: Linux kernel disables ps to pl clocks

Jump to solution

A lot of people have stumbled on this one, including us more than once. See if this helps:

 

http://forums.xilinx.com/t5/Embedded-Linux/Can-access-PL-register-from-u-boot-but-not-petalinux/m-p/647821#M13843

 

Xilinx Employee
Xilinx Employee
7,855 Views
Registered: ‎07-23-2012

Re: Linux kernel disables ps to pl clocks

Jump to solution
This is a known issue and got fixed in 2015.2.1.

In 2015.2, you need to edit the dts manually to enable FCLK.
-----------------------------------------------------------------------------------------------
Please mark the post as "Accept as solution" if the information provided answers your query/resolves your issue.

Give Kudos to a post which you think is helpful.
Voyager
Voyager
7,853 Views
Registered: ‎04-21-2014

Re: Linux kernel disables ps to pl clocks

Jump to solution

I'm not the OP, but thanks, good to know.

***Many of us who help you are just FPGA enthusiasts, and not Xilinx employees. If you receive help, and give kudos (star), you're likely to continue receiving help in the future. If you get a solution, please mark it as a solution.***
0 Kudos
Scholar sampatd
Scholar
7,837 Views
Registered: ‎09-05-2011

Re: Linux kernel disables ps to pl clocks

Jump to solution
The reason was that the device tree generator logic was failing to detect the presence of the FCLKs. Specifically, it was searching for signals named "FCLK" rather than "FCLK_CLK". This issue is resolved in the PetaLinux 2015.2.1 release.
0 Kudos
Visitor pa2ees42
Visitor
7,809 Views
Registered: ‎08-31-2015

Re: Linux kernel disables ps to pl clocks

Jump to solution

Thanks for all your replies.  The link rjsefton gave me led me to find a post by milosoftware, which ultimately fixed the problem.

 

add "fclk-enable = <0xf>;" to the "clkc" node (inside slcr) of the devicetree.

 

Mine was originally "fclk-enable = <0x0>;"

 

I am using arch linux on the microzed.

0 Kudos