UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
139 Views
Registered: ‎10-29-2018

Query on pin multiplexing for GEM0

We are using GEM0 for Ethernet in our design.

 

    pinctrl_ethernet0_default: ethernet0-default {
        mux {
            groups = "ethernet0_0_grp";
            function = "ethernet0";
        };

        conf {
            groups = "ethernet0_0_grp";
            slew-rate = <SLEW_RATE_SLOW>;
            io-standard = <IO_STANDARD_LVCMOS18>;
        };

        conf-rx {
            pins = "MIO32", "MIO33", "MIO34", "MIO35", "MIO36", "MIO37";
            bias-high-impedance;
            low-power-disable;
        };

        conf-tx {
            pins = "MIO26", "MIO27", "MIO28", "MIO29", "MIO30", "MIO31";
            low-power-enable;
            bias-disable;
        };

        mux-mdio {
            function = "mdio0";
            groups = "mdio0_0_grp";
        };

        conf-mdio {
            groups = "mdio0_0_grp";
            slew-rate = <SLEW_RATE_SLOW>;
            io-standard = <IO_STANDARD_LVCMOS18>;
            bias-disable;
        };
    };

The device tree entry for pin multiplexing the GEM0 Ethernet is as above. As per the Xilinx pinctrl binding documentation, I see four MDIO groups, mdio0_0_grp, mdio1_0_grp, mdio2_0_grp and mdio3_0_grp. Based on information on 1039 of the ZYNQMP TRM and this pinctrl binding, I expect the correct configuration for MDIO to be mdio0_0_grp, however, doing this and the driver crashes. If I keep mdio3_0_grp, it does not. I expect mdio0_0_grp to be correct, but, cannot understand the driver crash if I use mdio0_0_grp. I have attached a screenshot of the crash.

Can someone help me with the correct configuration if it is wrong and if configuration is correct, what else might be the problem? Currently, using kernel build with Yocto release v2018.2.

 

crash.png
0 Kudos
1 Reply
23 Views
Registered: ‎10-29-2018

Re: Query on pin multiplexing for GEM0

Can someone from Xilinx not even be bothered to reply?
0 Kudos