UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Explorer
Explorer
1,548 Views
Registered: ‎12-05-2012

Reasons for CDMA errors

Hello Guys,

 

I can successfully transfer data from PL TO PS using cdma and BRAM shared between PL and CDMA.

But, I want an interrupt generated from GPIO to start the data transfers then cdma fails to transfer data

 

I tried all I could first I tried working with multiple interrupts that is one interrupt from GPIO and other from CDMA.

 

The data transfer of cdma halted with an error of 20480 (14 bits).

 

I searched in the cdma datasheet and says it is because of a data tarnsfer error.

 

 

 

Now I tried by cdma polling Now the error is 64 (6 bits)

 

How come error occurs only if I use a GPIO interrupt to start the transfers. BTW the GPIO interrupt occurs perfectly and is detected.

 

I am presently using Xilinx 14.3 and axi cdma 3.03A .

Writing my applications in standalone PS.

Tags (3)
0 Kudos