UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Observer j_ney
Observer
459 Views
Registered: ‎11-26-2017

USB 3.0 ZCU102 Ubuntu

(Sorry for posting this again, I've posted it in the wrong location before)

Hello!

I've got a problem with connecting a USB 3.0 camera to the ZCU102 running Ubuntu. 

The camera seems to be only detected as USB 2.0 in Ubuntu. On my windows machine it works fine with USB 3.0.

I thought the reason may be the adapter because of this tread: https://forums.xilinx.com/t5/Evaluation-Boards/ZCU102-ES2-USB-3-0-Host-mode/td-p/749487

But now I've tested two micro USB to USB 3.0 adapter, both with the same result. (For example this one: amazon usb adapter)

I've configured the jumpers according to this post: https://www.xilinx.com/support/answers/69164.html

This is my jumper configuration: 

IMG_20190320_142811__01.jpg

This is the output of lsusb under Ubuntu:

lsusb.PNG

How can I confugure the board to use Bus 002 (which is 3.0) for my camera?

This is the output of usb-devices:

usb-devices.PNG

Thanks for any help!

 

0 Kudos
4 Replies
Xilinx Employee
Xilinx Employee
360 Views
Registered: ‎09-01-2014

Re: USB 3.0 ZCU102 Ubuntu

The only reason is the USB adapter,are you using the ZCU102 production board?
https://www.xilinx.com/support/answers/69151.html
0 Kudos
Observer j_ney
Observer
345 Views
Registered: ‎11-26-2017

Re: USB 3.0 ZCU102 Ubuntu

Thanks for your answer!

In the link it is recommanded to use the adapter from Whizz Systems, but I've problems with purchasing exactly this adapter in Europe.  

Could you also provide a link with another adapter that sould work?

 

0 Kudos
Xilinx Employee
Xilinx Employee
330 Views
Registered: ‎09-01-2014

Re: USB 3.0 ZCU102 Ubuntu

I don’t know how to purchase it. it’s shipped with the production ZCU102 board.
USB 3.0 is notoriously picky/finicky about cabling. USB 2.0 and USB 1.1 are so low speed that it’s not difficult to hit the line rates since it’s just D+/D-. With USB 3.0 the wiring of the transceiver wires inside the cable (plus the grounding) can make cables the “critical path” of a USB 3.0 connection. In short, don’t use cheap cables. Spend the time to locate quality cables and spend the money on them.

Maybe it’s also a HW/SW setting issue, since I don’t know your setting, please check other USB3 device like Mass storage
https://xilinx-wiki.atlassian.net/wiki/spaces/A/pages/18841729/Zynq+Ultrascale+MPSOC+Linux+USB+device+driver
Xilinx provides the pre-build bootimage in PetaLinux ZCU102 BSP. Just try it to check if USB3.0 can be connected with your adapter.
https://www.xilinx.com/support/download/index.html/content/xilinx/en/downloadNav/embedded-design-tools.html
0 Kudos
Observer j_ney
Observer
255 Views
Registered: ‎11-26-2017

Re: USB 3.0 ZCU102 Ubuntu

Thanks again!

I've tested with the prebuild image and another USB 3.0 device and a new USB 3.0 adapter, but the problem remains.

What I'm wondering about is that lsusb lists the device at BUS 1 which is declared as "2.0 root hub", while BUS 2 is declared as "3.0 root hub". (See the image in my first post)

From my understanding there are two USB conrollers on PS side, one for 3.0 and one for 2.0 but both are connected to the same output and you can change the configuration with jumpers. Is this correct?

Maybe my jumper configuration is somehow wrong, eventhough I think I've set them according to this link: https://www.xilinx.com/support/answers/69164.html

Do you think there could be another issue as the USB adapter?

0 Kudos