UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Participant nanjing2002
Participant
849 Views
Registered: ‎01-25-2014

Why Vivado latest version can not support old version design? How to solve it?

Now I'm using the vivado 2017.2. I download the example design from Xilinx website. However,many designs were developed in old version vivado. When I open it for example some scripts .tcl file.Failure occured and Tool indicated me to use old version.Then upgrade in 2017.2 version. But many example designs maybe designed by 2014.1,2015.2 or 2016.4 and son on. Should I install these version vivado at the same time? Obviously, it is very inconvenient. How to deal with it?

Thank you in advance.

0 Kudos
3 Replies
Xilinx Employee
Xilinx Employee
834 Views
Registered: ‎02-14-2014

Re: Why Vivado latest version can not support old version design? How to solve it?

Hello @nanjing2002,

 

Can you share links for designs, for which you couldn't find their latest versions (Vivado 2017.2 versions)?

Regards,
Ashish
----------------------------------------------------------------------------------------------
Kindly note- Please mark the Answer as "Accept as solution" if information provided is helpful.
Give Kudos to a post which you think is helpful and reply oriented.
----------------------------------------------------------------------------------------------
0 Kudos
Participant nanjing2002
Participant
822 Views
Registered: ‎01-25-2014

Re: Why Vivado latest version can not support old version design? How to solve it?

@ashishd For example,https://www.xilinx.com/support/answers/51779.html. Many design example were based on the old version.
0 Kudos
Xilinx Employee
Xilinx Employee
752 Views
Registered: ‎02-14-2014

Re: Why Vivado latest version can not support old version design? How to solve it?

Hi @nanjing2002,

 

Please check your PM.

Regards,
Ashish
----------------------------------------------------------------------------------------------
Kindly note- Please mark the Answer as "Accept as solution" if information provided is helpful.
Give Kudos to a post which you think is helpful and reply oriented.
----------------------------------------------------------------------------------------------
0 Kudos