UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Adventurer
Adventurer
131 Views
Registered: ‎01-24-2018

XILINX TTC Stand Alone Driver Examples Problem

I started here...

https://xilinx-wiki.atlassian.net/wiki/spaces/A/pages/18841648/TTC+Standalone+Driver

And ended up here...

https://github.com/Xilinx/embeddedsw/blob/master/XilinxProcessorIPLib/drivers/ttcps/examples/xttcps_rtc_example.c

Pretty simple example. I can build this with the Xilinx SDK easily enough.

I built one version for RPU0, and another version for RPU1.

If I bring the target (ZCU102) up and run one or the other, everything is fine.

If I run one, then try to run the other, it fails.

Can someone else try this, I do not understand what is going wrong.

Either one will run fine over and over again however if I run either one,

and then try to run the other one, it breaks. It is always the second one that

fails regardless of which one I run first.

 

0 Kudos
2 Replies
Explorer
Explorer
123 Views
Registered: ‎10-23-2018

Re: XILINX TTC Stand Alone Driver Examples Problem

@jrp

My guess would be that you are using two instances that have the same ID (or other common value). That may be causing the conflict.

0 Kudos
Adventurer
Adventurer
38 Views
Registered: ‎01-24-2018

Re: XILINX TTC Stand Alone Driver Examples Problem

Interesting... as it turns out, I fixed this

by removing the extra -DUSE_AMP=1 setting in the bsp's.

I must of picked that up from another project?

Now it works!

 

0 Kudos