UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Observer saiwing_hit
Observer
70 Views
Registered: ‎08-18-2017

why does cpu1 of zynq XC7Z020 seem to be damaged

hello, everyone

I am using zynq XC7Z020 SOC, during past half year, it run quite well.

However, days ago, I suddenly found CPU1 fails.

After power up,  register A9_CPU_RST_CTRL(0xF8000244)  has value 0x22( which means CPU1 clock stopped and CPU1 held in reset state).  CPU0 is OK.

I tried to clear A9_CPU_RST_CTRL, CPU1 still doesn't work. I also check pin PS_SRST_B and PS_POR_B, the timing sequence satisfy UG585 doc.

 

I am very sure both CPUs were ok before, but now I can only have CPU0 work.

 

What is the cause and how can I solve the problem

 

I will be very grateful for your advice.

0 Kudos