UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Visitor kyi
Visitor
393 Views
Registered: ‎12-11-2018

AXI Ethernet lose connection sporadically

Target FPGA : Zynq7z020

Vivado 2016.2, Petalinux 2016.2

Using AXI Ethernet, AXI DMA and those are connected to ACP port of PS. This ACP port is also shared with our custom DMA module (This DMA mostly read from RAM). Jumbo frame is set but the problem still happens in standard frame (1500B). Jumbo frame MTU is 9000B. We connected multiple target boards to one host server PC through a 10G-1G ethernet switch. We are using Marvell 88E1512, RGMII interface for phy chipset.

Problem symptom:

While running the stress test from PC to multiple target boards (2 or 4), randomly the ethernet connection is lost. This happens very rarely. 

1st test : connection drops from one target board at about 240GB data transfer

2nd test : connection drops from one target board at about 470GB data transfer

3, 4th test : connection drops from one target board at about 1.2TB data transfer

Debugging:

RJ45 lights are : Orange is ON, Green is always ON, not blinking. Network switch's light for the port of target board is off. All other ports in network switch are alive. If I change the connection of dropped port with a connection of a good target board, it works. This means network switch works fine.

I checked the software. I connected a serial communication to the target board and can run Linux shell commands. I ran a ethtool, ifconfig, and devmem to check the trimac registers. Software seems fine.

When I check the trimac registers, everything was good. There is no errors, no packet drops. I dumped some registers with ethtool and attached it to this post.

One important thing is that if I ran "ifconfig eth0 down" and "ifconfig eth0 up", then the link is up and everything works fine again.

[Tue Dec 11 08:37:11.758 2018] root@samba_fuji:~# xilinx_axienet 41000000.ethernet eth0: Link is Down
[Tue Dec 11 08:37:15.759 2018] xilinx_axienet 41000000.ethernet eth0: Link is Up - 1Gbps/Full - flow control off
[Tue Dec 11 08:37:15.759 2018] IPv6: ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready

Since after I reset the AXI MAC with ifconfig command, the MAC and PHY works again, I can't dismiss the idea that there is something wrong in the lower layer (layer 1 or layer 2).

Please help us on stabilizing the AXI ethernet connection.

Appreciated.

 

 

Tags (1)
0 Kudos
2 Replies
Moderator
Moderator
313 Views
Registered: ‎12-04-2016

Re: AXI Ethernet lose connection sporadically

Hi

Is the same issue seen across all the speeds? I mean did you check with other speeds 10/100Mbps and found link stable?

 

Best Regards

Shabbir

0 Kudos
Visitor kyi
Visitor
301 Views
Registered: ‎12-11-2018

Re: AXI Ethernet lose connection sporadically

Hi Shabbir,

Currently, I am testing a patch in phy.c and xilinx_axienet_mdio.c.

 

Regards,

0 Kudos