UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Visitor kishorep
Visitor
529 Views
Registered: ‎11-15-2017

Ethernet on custom 7030 board not working

Hello All,

  We are working on Zynq 7030 customized board with DP83867IR transceiver , where I am unable to ping custom board to/from other PC(in same network), But  able to ping in U-boot and  also able to get loopback response.

 

ifconfig output:

 

eth0      Link encap:Ethernet  HWaddr 00:0A:35:00:01:22
          inet addr:192.168.2.222  Bcast:192.168.3.255  Mask:255.255.252.0
          inet6 addr: fe80::20a:35ff:fe00:122/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:3096 dropped:0 overruns:0 frame:3096
          TX packets:15 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:1054 (1.0 KiB)
          Interrupt:29 Base address:0xc000
 
dts file configuration:
 
&gem1 {
    status = "okay";
    phy-mode = "rgmii-id";
    phy-handle = <&ethernet_phy>;
    pinctrl-names = "default";
    pinctrl-0 = <&pinctrl_gem1_default>;
        

    ethernet_phy: ethernet-phy@30 {
        reg = <30>;
                ti,rx-internal-delay = <0x8>;
                ti,tx-internal-delay = <0xa>;
                ti,fifo-depth = <0x1>;
        device_type = "ethernet-phy";
                ti,rxctrl-strap-worka;
    };
};
 
If i tried to ping to other pc from my custom board following message come:
 
/ # ping 192.168.3.241
PING 192.168.3.241 (192.168.3.241): 56 data bytes
 
^C
--- 192.168.3.241 ping statistics ---
134 packets transmitted, 0 packets received, 100% packet loss
 
Is their any extra modification needed in the kernel to avoid RX packet loss
( RX packets:0 errors:3096 dropped:0 overruns:0 frame:3096)

 

please help me sort out this issue...

 

Regards,

Kishore P

 

Tags (1)
0 Kudos